Cron job with ECC SSL Piwik installation


#1

Does the Piwik command-line archiver ( How to Set up Auto-Archiving of Your Reports - Analytics Platform - Matomo ) works with a Piwik installation that is using an ECC SSL certificate?


# /usr/bin/php <my_path_to_piwik> core:archive --url=https://rin.vocaloid.my/
INFO CoreConsole[2014-09-05 07:21:05] [73980] ---------------------------
INFO CoreConsole[2014-09-05 07:21:05] [73980] INIT
INFO CoreConsole[2014-09-05 07:21:05] [73980] Piwik is installed at: https://rin.vocaloid.my/index.php
INFO CoreConsole[2014-09-05 07:21:05] [73980] Running Piwik 2.6.1 as Super User
ERROR CoreConsole[2014-09-05 07:21:05] [73980] Got invalid response from API request: https://rin.vocaloid.my/index.php?module=API&method=API.getDefaultMetricTranslations&format=original&serialize=1&trigger=archivephp. Response was 'Got invalid response from API request: https://rin.vocaloid.my/index.php?module=API&method=API.getDefaultMetricTranslations&format=original&serialize=1&trigger=archivephp. Response was 'curl_exec: SSL connect error. Hostname requested was: rin.vocaloid.my''
ERROR CoreConsole[2014-09-05 07:21:05] [73980] Got invalid response from API request: https://rin.vocaloid.my/index.php?module=API&method=API.getDefaultMetricTranslations&format=original&serialize=1&trigger=archivephp. Response was 'Got invalid response from API request: https://rin.vocaloid.my/index.php?module=API&method=API.getDefaultMetricTranslations&format=original&serialize=1&trigger=archivephp. Response was 'curl_exec: SSL connect error. Hostname requested was: rin.vocaloid.my''
ERROR CoreConsole[2014-09-05 07:21:05] [73980] The Piwik URL https://rin.vocaloid.my/index.php does not seem to be pointing to a Piwik server. Response was ''.
ERROR CoreConsole[2014-09-05 07:21:05] [73980] The Piwik URL https://rin.vocaloid.my/index.php does not seem to be pointing to a Piwik server. Response was ''.

Piwik is the latest version, server is CentOS 6 and PHP version is 5.5.16.


(Matthieu Aubry) #2

Add the parameter --accept-invalid-ssl-certificate and it should work?


--accept-invalid-ssl-certificate   It is _NOT_ recommended to use this argument. Instead, you should use a valid SSL certificate!
                                    It can be useful if you specified --url=https://... or if you are using Piwik with force_ssl=1


#3

Still the same error message.


# /usr/bin/php <my_path_to_piwik_console> core:archive --url=https://rin.vocaloid.my/ --accept-invalid-ssl-certificate
INFO CoreConsole[2014-09-06 21:47:53] [45176] ---------------------------
INFO CoreConsole[2014-09-06 21:47:53] [45176] INIT
INFO CoreConsole[2014-09-06 21:47:53] [45176] Piwik is installed at: https://rin.vocaloid.my/index.php
INFO CoreConsole[2014-09-06 21:47:53] [45176] Running Piwik 2.6.1 as Super User
ERROR CoreConsole[2014-09-06 21:47:53] [45176] Got invalid response from API request: https://rin.vocaloid.my/index.php?module=API&method=API.getDefaultMetricTranslations&format=original&serialize=1&trigger=archivephp. Response was 'Got invalid response from API request: https://rin.vocaloid.my/index.php?module=API&method=API.getDefaultMetricTranslations&format=original&serialize=1&trigger=archivephp. Response was 'curl_exec: SSL connect error. Hostname requested was: rin.vocaloid.my''
ERROR CoreConsole[2014-09-06 21:47:53] [45176] Got invalid response from API request: https://rin.vocaloid.my/index.php?module=API&method=API.getDefaultMetricTranslations&format=original&serialize=1&trigger=archivephp. Response was 'Got invalid response from API request: https://rin.vocaloid.my/index.php?module=API&method=API.getDefaultMetricTranslations&format=original&serialize=1&trigger=archivephp. Response was 'curl_exec: SSL connect error. Hostname requested was: rin.vocaloid.my''
ERROR CoreConsole[2014-09-06 21:47:53] [45176] The Piwik URL https://rin.vocaloid.my/index.php does not seem to be pointing to a Piwik server. Response was ''.
ERROR CoreConsole[2014-09-06 21:47:53] [45176] The Piwik URL https://rin.vocaloid.my/index.php does not seem to be pointing to a Piwik server. Response was ''.