Cron Job Error API

(Dan) #1


I incresed the memory limit twice as suggested but still get this error mail every 5 mins :frowning:

What can I do?



ERROR Piwik\Access[2014-10-20 14:05:01] [d0c0b] Got invalid response from API request: http://xxxx/piwik/index.php?module=API&method=API.getDefaultMetricTranslations&format=original&serialize=1&trigger=archivephp. The response was empty. This usually means a server error. This solution to this error is generally to increase the value of ‘memory_limit’ in your php.ini file. Please check your Web server Error Log file for more details.
ERROR Piwik\Access[2014-10-20 14:05:01] [d0c0b] The Piwik URL does not seem to be pointing to a Piwik server. Response was ‘’.

(Matthieu Aubry) #2

Check your server error log, do you see anything in there?

(Dan) #3

HI MAtt,


see this

[20-Oct-2014 12:35:20 UTC] PHP Fatal error: Class ‘Piwik_Plugin’ not found in /home/trinkgu/public_html/ on line 17
[20-Oct-2014 12:36:05 UTC] PHP Fatal error: Class ‘Piwik_Plugin’ not found in /home/trinkgu/public_html/ on line 17
[20-Oct-2014 12:36:20 UTC] PHP Fatal error: Class ‘Piwik_Plugin’ not found in /home/trinkgu/public_html/ on line 17
[20-Oct-2014 12:48:24 UTC] Error in Piwik: Das Datumsformat muss YYYY-MM-DD, or ‘today’ or ‘yesterday’ oder eine andere, von der Funktion strtotime unterstützte Zeichenkette sein. (Besuchen Sie PHP: strtotime - Manual für nähere Informationen):

? is this the reason?



(Matthieu Aubry) #4

Alright you can download the new ones from:

Likely you were using Piwik from before 2.0 and so you may have to manually update those two plugins (or use Marketplace from within Piwik?)

(Dan) #5

Hi Matt,

yes am long time user :slight_smile:

Thx :slight_smile:

Are there specific instructions how to update existing plugins?

Sorry :frowning: am no server expert

Thanks a million


(Matthieu Aubry) #6

Go to Settings > Marketplace > can you there install the SecurityInfo and Visitorgenerator plugins?

(Dan) #7



yes, and the problem resolved with the update to 2.8.1