Cron en erreur


(Damien DS) #1

Bonjour,

depuis la mise à jour en v2.1.0 de Piwik, j’ai cette erreur avec l’excecution d’une tache cron :


Running Piwik 2.1.0 as Super User: **********************************************
ERROR: Got invalid response from API request: http://www.adressedupiwik/misc/cron/../../index.php?module=API&method=API.getDefaultMetricTranslations&format=original&serialize=1&trigger=archivephp. Response was '<br /><b>Parse error</b>:  syntax error, unexpected T_STRING in <b>/chemin/misc/cron/archive.php</b> on line <b>12</b><br />'
ERROR: The Piwik URL http://www.adressedupiwik/misc/cron/../../index.php does not seem to be pointing to a Piwik server. Response was ''.

Si vous avez une idée du pourquoi, je suis preneur ^^
Merci d’avance pour votre aide.


(Matthieu Aubry) #2

re-upload tous les fichiers il semble que certains fichiers (comme misc/user/archive.php) ne sont pas uploades correctement


(Damien DS) #3

Bonjour,

j’ai re-uploadé tous les fichiers de la dernière version de Piwik est j’ai le même résultat.

En suivant ce post : 301 Moved Permanently (modification du fichier CliMulti.php), j’ai ce message qui s’ajoute au précédent :


string(20) "1/usr/local/bin/php " string(20) "2/usr/local/bin/php " string(20) "1/usr/local/bin/php " string(20) "2/usr/local/bin/php "

Pour info la version de php est v5.3.2


(Matthieu Aubry) #4

Testez la derniere version beta (2.1.1-beta8+)


#5

Hi,

I’m facing to that 2 errors when I’m trying to update Piwik with archive.php.
My problem is that my website is on a shared hosting and I can’t manage cron as I would like.

INFO ERROR: Got invalid response from API request: http://your-server.org/path/to/piwik/index.php?module=API&method=API.getDefaultMetricTranslations&format=original&serialize=1&trigger=archivephp. Response was ‘
Warning: Unexpected character in input: ‘’ (ASCII=92) state=1 in http://your-server.org/path/to/piwik/console on line 20

Parse error: syntax error, unexpected T_STRING in http://your-server.org/path/to/piwik/console on line 20

INFO Piwik\CronArchiveFatalException ERROR: The Piwik URL http://your-server.org/path/to/piwik/index.php does not seem to be pointing to a Piwik server. Response was ‘’.

Hope someone can help me, I encounter this problem since 2.1.0 update of Piwik, the same with 2.2.0.

Thanks in advance.


(Matthieu Aubry) #6

Le PHP CLI executable (que le cron fait tourner) n’est pas un PHP 5.3 +. Demande a ton hebergeur de mettre a jour PHP CLI en PHP 5.3 ou 5.5


(Damien DS) #7

Bonjour,

Je suis passé sur la version PHP 5.5.11 et Piwik en 2.2.0 mais j’ai le même soucis :


Using this ‘archive.php’ script is no longer recommended.
Please use ‘/path/to/php /cheminPiwik/console core:archive – url=http://monPiwik/’ instead.
To get help use ‘/path/to/php /home/dspservi/www/stats/console core:archive --help’

INFO [2014-04-28 06:25:45] [3aba2] ---------------------------
INFO [2014-04-28 06:25:45] [3aba2] INIT
INFO [2014-04-28 06:25:45] [3aba2] Piwik is installed at: http://monPiwik/index.php
INFO [2014-04-28 06:25:45] [3aba2] Running Piwik 2.2.0 as Super User
INFO [2014-04-28 06:25:53] [3aba2] ERROR: Got invalid response from API request: http://monPiwik/index.php?module=API&method=API.getDefaultMetricTranslations&format=original&serialize=1&trigger=archivephp. Response was '

Fatal error: Directive ‘allow_call_time_pass_reference’ is no longer available in PHP in Unknown on line 0


INFO Piwik\CronArchiveFatalException[2014-04-28 06:25:53] [3aba2] ERROR: The Piwik URL http://monPiwik/index.php does not seem to be pointing to a Piwik server. Response was ‘’.
Error in the last Piwik archive.php run:
The Piwik URL http://monPiwik/index.php does not seem to be pointing to a Piwik server. Response was ‘’.

Here is the full errors output:


INIT
Piwik is installed at: http://monPiwik/index.php
Running Piwik 2.2.0 as Super User
ERROR: Got invalid response from API request: http://monPiwik/index.php?module=API&method=API.getDefaultMetricTranslations&format=original&serialize=1&trigger=archivephp. Response was '

Fatal error: Directive ‘allow_call_time_pass_reference’ is no longer available in PHP in Unknown on line 0

J’espère que l’on va trouver une solution rapidement :slight_smile:


(Matthieu Aubry) #8

mettez a jour le cron comme explique sur: How to Set up Auto-Archiving of Your Reports - Analytics Platform - Matomo
est ce que ca corrige le probleme?


(Damien DS) #9

Je viens de faire un essai en mettant à jour la ligne de commande pour le cron, et j’ai un nouveau message d’erreur :


<br />
<b>Warning</b>:  date(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone. in <b>/MoncheminPiwik/core/Log.php</b> on line <b>520</b><br />
INFO CoreConsole[2014-04-28 14:06:01] [c8533] ---------------------------
<br />
<b>Warning</b>:  date(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone. in <b>/MoncheminPiwik/core/Log.php</b> on line <b>520</b><br />
INFO CoreConsole[2014-04-28 14:06:01] [c8533] INIT
<br />
<b>Warning</b>:  date(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone. in <b>/MoncheminPiwik/core/Log.php</b> on line <b>520</b><br />
INFO CoreConsole[2014-04-28 14:06:01] [c8533] Piwik is installed at: http://monPiwik/index.php
<br />
<b>Warning</b>:  date(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone. in <b>/MoncheminPiwik/core/Log.php</b> on line <b>520</b><br />
INFO CoreConsole[2014-04-28 14:06:01] [c8533] Running Piwik 2.2.0 as Super User
<br />
<b>Warning</b>:  strtotime(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone. in <b>/MoncheminPiwik/core/CliMulti.php</b> on line <b>176</b><br />
<br />
<b>Warning</b>:  date(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone. in <b>/MoncheminPiwik/core/Log.php</b> on line <b>520</b><br />
INFO CoreConsole[2014-04-28 14:06:10] [c8533] ERROR: Got invalid response from API request: http://monPiwik/index.php?module=API&method=API.getDefaultMetricTranslations&format=original&serialize=1&trigger=archivephp. Response was '<br />
<b>Fatal error</b>:  Directive 'allow_call_time_pass_reference' is no longer available in PHP in <b>Unknown</b> on line <b>0</b><br />
'
<br />
<b>Warning</b>:  date(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone. in <b>/MoncheminPiwik/core/Log.php</b> on line <b>520</b><br />
INFO CoreConsole[2014-04-28 14:06:10] [c8533] ERROR: The Piwik URL http://monPiwik/index.php does not seem to be pointing to a Piwik server. Response was ''.
Error in the last Piwik archive.php run:
The Piwik URL http://monPiwik/index.php does not seem to be pointing to a Piwik server. Response was ''.


 Here is the full errors output:

---------------------------
INIT

Piwik is installed at: http://monPiwik/index.php
Running Piwik 2.2.0 as Super User
ERROR: Got invalid response from API request: http://monPiwik/index.php?module=API&method=API.getDefaultMetricTranslations&format=original&serialize=1&trigger=archivephp. Response was '<br />
<b>Fatal error</b>:  Directive 'allow_call_time_pass_reference' is no longer available in PHP in <b>Unknown</b> on line <b>0</b><br />

On avance ?! :wink:


(Damien DS) #10

Je viens de faire un essai en mettant à jour la ligne de commande pour le cron, et j’ai un nouveau message d’erreur :


<br />
<b>Warning</b>:  date(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone. in <b>/MoncheminPiwik/core/Log.php</b> on line <b>520</b><br />
INFO CoreConsole[2014-04-28 14:06:01] [c8533] ---------------------------
<br />
<b>Warning</b>:  date(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone. in <b>/MoncheminPiwik/core/Log.php</b> on line <b>520</b><br />
INFO CoreConsole[2014-04-28 14:06:01] [c8533] INIT
<br />
<b>Warning</b>:  date(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone. in <b>/MoncheminPiwik/core/Log.php</b> on line <b>520</b><br />
INFO CoreConsole[2014-04-28 14:06:01] [c8533] Piwik is installed at: http://monPiwik/index.php
<br />
<b>Warning</b>:  date(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone. in <b>/MoncheminPiwik/core/Log.php</b> on line <b>520</b><br />
INFO CoreConsole[2014-04-28 14:06:01] [c8533] Running Piwik 2.2.0 as Super User
<br />
<b>Warning</b>:  strtotime(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone. in <b>/MoncheminPiwik/core/CliMulti.php</b> on line <b>176</b><br />
<br />
<b>Warning</b>:  date(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone. in <b>/MoncheminPiwik/core/Log.php</b> on line <b>520</b><br />
INFO CoreConsole[2014-04-28 14:06:10] [c8533] ERROR: Got invalid response from API request: http://monPiwik/index.php?module=API&method=API.getDefaultMetricTranslations&format=original&serialize=1&trigger=archivephp. Response was '<br />
<b>Fatal error</b>:  Directive 'allow_call_time_pass_reference' is no longer available in PHP in <b>Unknown</b> on line <b>0</b><br />
'
<br />
<b>Warning</b>:  date(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone. in <b>/MoncheminPiwik/core/Log.php</b> on line <b>520</b><br />
INFO CoreConsole[2014-04-28 14:06:10] [c8533] ERROR: The Piwik URL http://monPiwik/index.php does not seem to be pointing to a Piwik server. Response was ''.
Error in the last Piwik archive.php run:
The Piwik URL http://monPiwik/index.php does not seem to be pointing to a Piwik server. Response was ''.


 Here is the full errors output:

---------------------------
INIT

Piwik is installed at: http://monPiwik/index.php
Running Piwik 2.2.0 as Super User
ERROR: Got invalid response from API request: http://monPiwik/index.php?module=API&method=API.getDefaultMetricTranslations&format=original&serialize=1&trigger=archivephp. Response was '<br />
<b>Fatal error</b>:  Directive 'allow_call_time_pass_reference' is no longer available in PHP in <b>Unknown</b> on line <b>0</b><br />

On avance ?! :wink: