Cron Archive ini_set problem + fix


#1

Updated to 1.5 piwik and ran into a cron bug.

The shell script archive.sh runs piwik code plus some zend code that requires ini_set to be enabled. Most hosts have this disabled (or should) and as such, the shell script fails.

The fix is:

Copy/paste your ini file from your root dir to the misc/cron folder - edit to remove ini_set from the disable list

then in the cron/misc/archive.sh file, find replace

$PHP_BIN -q

with

$PHP_BIN -q -c /home/FULL PATH TO/www/piwik/misc/cron/php.ini

I think there are a half dozen instances.

This tells the command line to load your edited ini file with ini_set allowed and lets the script run.


Steve