Country detection inaccurate, please help!


we have a company intranet which is only accessed throughout different cities within Canada. Originally, (from the default Piwik installation), virtually all visitors indicated that they were from USA and one from Canada.
After looking around in these forum posts, I followed instructions to install GeoIP for more accuracy (Plugin using GeoIP to accurately detect visitor countries, cities, and continent · Issue #5465 · matomo-org/matomo · GitHub).

Now, I’m receiving visits to many different countries throughout the world, which is even more inaccurate, as the company intranet should only be accessed from select cities in Canada.

Can somebody tell me why this is happening and how to fix this?
Thank you.

I can’t comment on GeoIP. You’ll have to ask Maxmind.

This is explained in the FAQ. Piwik by default guesses the visitor’s country from the browser language. ‘en-ca’ (or fr-ca) would be your Canadian visitor; the rest are probably using ‘en-us’.

Ok, thanks for your reply!

After installing GepIP and enabling it, I’m receiving a lot of referral spam and sites/keywords that are clearly not applicable to our website. Is there any way of fixing this?

Thanks in advance.

Referer spam isn’t a side effect of GeoIp.

The most likely cause is Microsoft’s Bing bot. This should already be filtered if you’re using 0.4.3.

Yes, I am using version 0.4.3. How can I filter this?

We’ve updated the filter for 0.4.4. We’re hoping to release this update this week.

Sorry for the delay. 0.4.4 is now available for download.

thanks a lot

Good news: GeoIP is now integrated in Piwik, enabling Accurate Visitors Geolocation in your Analytics reports. To enable GeoIP go to the Settings > Geolocation admin page, and follow the short instructions.

You can also get an even more accurate Country & City Database from here to enjoy top accuracy in detecting your visitors locations.

See also the documentation about Geolocation - Analytics Reports in Piwik.