Config.ini.php No such file or directory


#1

Hello

I just tried to install Matomo on a small Webhosting but the web based installer says:

The configuration file {/var/www/vhosts/hosting7474.af949.netcup.net/httpdocs/piwik/config/config.ini.php} has not been found or could not be read.

So I tried to make writeable but there is no such file…

cd var/www/
wget https://builds.piwik.org/piwik.zip
unzip *zip
chmod a+w piwik/config/config.ini.php
   → chmod: cannot access `piwik/config/config.ini.php': No such file or directory

ls  piwik/config/
   → environment  global.ini.php  global.php  manifest.inc.php

Maybe I have to change permissions? But I can only use chmod not chown.


(Fabian Dellwing) #2

This file should be created by the web installer. Does your webserver have write permission on the config directory?


#3

I think yes. I have done
chmod a+w piwik/config/
after unpacking.

But its strange, it asks me while unpacking:
replace How to install Matomo.html? [y]es, [n]o, [A]ll, [N]one, [r]ename:

Other strange thing, web installer is only html, no css, looking very old. I have SSL enabled.


(Fabian Dellwing) #4

Why is that strange? That file already exists and unzip is asking for your permisson to override it.

Can you provide a link to your piwik instance? If you don’t want to post it here, consider writing it as PM.


#5

Strange because I removed piwik folder before I unpacked again. Ok, just found that this one file is outside of piwik folder :slight_smile:

I would send you link, but I am not sure how to send private message.


(Fabian Dellwing) #6

Click on my name and then on “message”.


#7

There is no message, maybe because I am new registered, regards


#8

Its a little bit slow, 50 cent webhosting and there are already a prestashops running :slight_smile:
Maybe thats the problem, that is is in she shop root of Prestashop 1.7.
But ist only for testing reasons no productive :slight_smile:


(Fabian Dellwing) #9

Your site works for me and I was able to run the system check, but there is problem with your PHP and I dont think your hoster allows you to change the php.ini.


#10

Problem with CSS was AdBlock (UBlock Origin)


#11

I installed it on the same hosting some time ago.

Only problem is:
always_populate_raw_post_data=-1 #not set

But PHP version is 5.6.33 , and if have read always_populate_raw_post_data is deprecated and is commented out in this version.


(Fabian Dellwing) #12

You could try it with a .htaccess in your matomo root. Put the following line in it:

php_value always_populate_raw_post_data -1


#13

Not working
But I was able to change version to 5.5 (CGI/FastCGI) now it is working.
Thanks for the help !


(Fabian Dellwing) #14

Yes, the option is only needed for PHP 5.6. Glad it worked out, have a nice day.