Cloud Works, Self Hosted Does Not "No data has been recorded yet"


#1

Hello all,

I first set up tracking for an internal website with Matomo Cloud Hosting.
It’s been working fine.

I completed the setup of a Matomo Self Hosted instance on another internal server.
Registered the same internal site there, but
after two days it still displays “No data has been recorded yet”.

The Tracking Script for both is on all the pages.
The script for the Self Hosted instance looks correct, it matches what is in the website setup screen in the Self Hosted Matomo…

On the Web App Server being tracked I can access the Self Hosted site in a browser,
and can reach the /piwik.php file there which displays “This resource is part of Matomo. …”

I tried swapping the order of the tracking scripts on the page,
and tried renaming all the var-s in the script from the Self Hosted site,
neither of these steps made any difference.

This leads me to believe it is not a connectivity issue, I see no reason the Web App should have any trouble sending data to the Self Hosted site.

What else could be allowing the Cloud Hosted version to work, but the Self Hosted version is not?

Thank you for considering my question!

much appreciated,


(Lukas Winkler) #2

Hi,

Keep in mind that you can’t just paste two Matomo tracking codes into one website as the scripts collide. If you want to track into two servers, please follow this guide:

https://developer.matomo.org/guides/tracking-javascript-guide#collect-your-analytics-data-into-two-or-more-piwik-servers


#3

Thank You Lucas!

The scripts colliding was something I suspected and
I had tried changing the variable names, but I changed too many of them.
This page I did not find in my searching about the issue.
The example here only had to change two of the variables.

I had to change the website id to one to match the Self Hosted instance.
Site hits are being recorded now!

very much appreciated!