Certificate error on update to 2.12.1 (solved)(tu)


#1

Hi,

I tried to start the one-click update from 2.12.0 to 2.12.1 and got a certificate error (screenshot attached).
My Piwik site is running on a Windows 2008 R2 Server (IIS 7.5) with PHP 5.5.21 and is SSL secured, too.

Does anyone have an idea?

Thanks, Klaus


(Youlike) #2

All update yet ? window and any programs.


#3

Yes, everything is updated as provided by our hosting provider and Plesk, resp. Windows updates were installed last week by our hosting provider (we cannot install them ourselves). Plesk is running version 12.0.18 Update 39.

Klaus


#4

Hello,

the problem is solved: cURL was missing CA info.
Solution:
[ol]
[li] Download cacert.pem from http://curl.haxx.se/ca/cacert.pem
[/li][li] Update php.ini and set curl.cainfo = “ABSOLUTE_PATH_TO/cacert.pem”
[/li][li] Recycle IIS Application Pool
[/li][/ol]


#5

Thanks for the fix, kondrich. This worked for me also.


#6

I try this but has no effect


(bolero) #7

You want to tell more :wink:


#8

So I checked the perms and all is ok. But have the same error


(bolero) #9

No, you don’t have the same error. You may have had the same error in the beginning (we don’t know). But now that you tried to resolve it there is a different error. AFAIK the path cannot be found/used.


(Matthieu Aubry) #10

Hi guys

we will fix this issue in Piwik in the next version - please see: Auto update over HTTPS can fail · Issue #7576 · matomo-org/piwik · GitHub


#11

This is ridiculous. Another version… more issues. More time spent researching what to do now…

curl_exec: error setting certificate verify locations: CAfile: c:\cacert.pem CApath: none. Hostname requested was: builds.piwik.org

Per post above, path can’t be used? Why not?

What is the solution…?


(bolero) #12

This is most likely an error specific to your platform (Windows). curl is probably not allowed to access this path or you have to specify the path in php.ini differently. It’s really not a Piwik problem, but either a Windows or php problem. You can apply the patch against the other SSL error to resolve this. The patch gives you the option to upgrade via http. -> Auto update over HTTPS can fail · Issue #7576 · matomo-org/piwik · GitHub

Kondrich, maybe it would help people if you gave the exact path you used. It seems people have problems with setting this, I suspect there may be permission problems on Windows systems if you set it to the root of C:
Also, if you added your own section of [curl] or where you added it.


#13

For me Matt’s solution solved the issue. Thnx


(bolero) #14

Remmeber, it doesn’t fix the underlying issue, it gives you the option to update via http. That’s a difference.


#15

Maybe it would help everyone if we understood how this became an issue just recently? I gave everyone permission to that file so it shouldn’t be permission issues. The fact the error now shows the new path means the ini should be correct. However, there still seems to be something missing per the error maybe.


(bolero) #16

Maybe set it to an incorrect path and check if you get the same error again. Also, I’m not sure how curl on Windows works. Does php install it (as a curl.dll, curl.exe or so) or do you have to install it separately? If you can use curl from the command line on Windows you can check if it shows the same problem as via php.

I had another issue with curl on Linux with this update and first thought, the way above might be the solution. So, I tried it and at one point I mistyped the path and I think I got exactly that error above. So, it very much looks to me like curl isn’t able to find this path. Either because it is not allowed or because it needs it differently (maybe slashes instead of backslashes or so?).

Why it becomes an issue only now? Because 2.12.0 had new update code that wants to retrieve the files via https.


(Matthieu Aubry) #17

Maybe it would help everyone if we understood how this became an issue just recently?

because it was implemented recently: Update Piwik over HTTPS by mnapoli · Pull Request #7327 · matomo-org/piwik · GitHub