Can't log in after update to version 3.8.0


(Kim) #1

Since up updating to version 3.8.0 I have been unable to log in. I have tried changing the password but with no success. I just can’t get past the sign in page.


Seit update ist anmeldung nicht mehr möglich!
(Lukas Winkler) #2

Hi,

Can you try deleting your cookies? Or try deleting the content of the matomo_session/piwik_session db table?


(Kim) #3

I have deleted the content of the matomo_session / piwik_session db table

Now get the following

Error : Form security failed. Please reload the form and check that your cookies are enabled. If you use a proxy server, you must configure Matomo to accept the proxy header that forwards the Host header. Also, check that your Referrer header is sent correctly.

I am not using a proxy server


(Lukas Winkler) #4

Did you also delete the local cookie?


(Kim) #5

Yes cookies deleted, still can’t log in


(Jacek) #6

I have the same problem. cookies deleted, content table (matomo_session) is empty. the problem occurred immediately after the update.


(Tpimpao) #7

Hi there, same problem here! I’m using LoginLdap plugin. I can login using a local user (admin).

Thanks,
TP


(Jacek) #8

the reason was cookies.
I use chrome, its automatic cleaning does not help. I used “ccleaner” and manually checked all folders (they were clean).
now everything works as it should.
Thanks!


Cannot login following 3.8.0 upgrade
(Kim) #9

Yes deep cleaning cookies is needed, finally got it to work.


#10

I got the same problem updated matomo to 3.8 with Firefox.

If you have the menu bar on the top of the tabs, go to Tools/Web Developer/Storage Inspector, then you can select the cookies you need to delete.
With the “Burger” on the right side, it’s similar = click on it then Web Developer/Storage Inspector …

There is a very simple way a lot more “radical” as it delete all the cookies of the website you are on…
So click where the i/locker (just before the URL)
Screenshot%20at%202019-01-24%2010-57-05
(don’t do it on the matomo forum but on your statistics website)
A window open, click at the bottom on “Clear Cookies and Site Data…” and follow what it tells you :wink:


(Laurence 'Green Reaper' Parry) #11

I suspect this is the bug I ran into, or something similar. It’s especially likely if you have Matamo/Piwik under a path, e.g. https://something.com/piwik/ because this can lead to the old cookie for the /piwik/ path overriding a new session’s / cookie - both end up being sent but /piwik/ has priority.


#12

Could anyone who experienced this issue see what their session.cookie_path PHP INI setting is set to (preferrably by seeing what ini_get(‘session.cookie_path’) returns when accessing matomo)? This would help confirm GreenReaper’s suspicion.