Can't Install Piwik on BlueHost. Error: always_populate_raw_post_data=-1

I have my site hosted at Bluehost. I have read all (I believe) posts here that relates to this error, but none could helped.

I tried using php.ini and edited it, I tried creating the .htaccess file in piwik folder, in public_html folder and so on.

Have anyone got that working on bluehost?

Their technical support didn’t helped, they said:

“Unfortunately I am not able to install Piwik.
Checked with specialists and they insist to install it manually with the help of a developer.
Yes, I have. And it is something that needs to be edited in php.ini
Since this is a 3rd party software, we cannot provide much support. Because this is something out of our scope of support.”


Try to rename the php.ini to .user.ini in the piwik folder with following content

On one host this did it for me, on a different one (Host Europe) I had no success with either the .user.ini, the php.ini nor a modified .htaccess. In fact, I couldn’t use the .htaccess at all in my hosting surrounding, would have to upgrade it.

Other possible option in the .htaccess:
php_value always_populate_raw_post_data -1

It is definitiely a bug with PHP 5.6 so if you have the option to downgrade tp PHP 5.5 (and this not affecting the rest) you could try this too.

OH MY GOD!! THanks! :smiley:
It dit work!!

Just to let anyone out there that use BlueHost give @Plan17 answer a try.

Inside the folder you installed Piwik create a file with this name .user.ini them inside it I added this code:



Saved and try to install Again! For me it worked. Thanks again!