Can't get full year reports


#1

I normally request yesterday’s daily information. Today I tried to select “year” on the date range dropdown. I could select it, but it would’t fetch data or close on its own. I tried this with “Month” as well. No luck. I then edited the URL to change the period to “year” and day to 2014. It cooked for a long time and then finally gave me a

Oops… there was a problem during the request. Maybe the server had a temporary issue, or maybe you requested a report with too much data.

It just wouldn’t do it despite repeated attempts.

Any thoughts? My data is good.


#2

I checked my log since I run hourly updates. I was looking for a year’s report for 2014 for site 3. As you can see, the archiver did generate the report, but when I attempted to view it (the dropdown just stopped working with the newest stable release) by requesting via URL, the app just timed out and gave me the “sorry” message. Below is my log to show that the reports are being generated correctly. These are low traffic sites, so there can’t be a data issue.

Archived website id = 1, period = day, 336 visits in last last2 days, 95 visits today, Time elapsed: 3.951s
INFO CoreConsole[2014-08-28 16:00:14] [a325b] Archived website id = 1, period = week, 2984 visits in last last2 weeks, 895 visits this week, Time elapsed: 6.918s
INFO CoreConsole[2014-08-28 16:00:53] [a325b] Archived website id = 1, period = month, 20549 visits in last last2 months, 11407 visits this month, Time elapsed: 39.417s
INFO CoreConsole[2014-08-28 16:01:43] [a325b] Archived website id = 1, period = year, 266718 visits in last last2 years, 91091 visits this year, Time elapsed: 49.364s
INFO CoreConsole[2014-08-28 16:01:43] [a325b] Archived website id = 1, 4 API requests, Time elapsed: 99.658s [1/2 done]
INFO CoreConsole[2014-08-28 16:01:47] [a325b] Archived website id = 3, period = day, 570 visits in last last2 days, 165 visits today, Time elapsed: 4.365s
INFO CoreConsole[2014-08-28 16:01:54] [a325b] Archived website id = 3, period = week, 4230 visits in last last2 weeks, 1450 visits this week, Time elapsed: 7.090s
INFO CoreConsole[2014-08-28 16:02:37] [a325b] Archived website id = 3, period = month, 21415 visits in last last2 months, 10911 visits this month, Time elapsed: 42.911s
INFO CoreConsole[2014-08-28 16:03:06] [a325b] Archived website id = 3, period = year, 48468 visits in last last2 years, 48468 visits this year, Time elapsed: 29.267s
INFO CoreConsole[2014-08-28 16:03:06] [a325b] Archived website id = 3, 4 API requests, Time elapsed: 83.641s [2/2 done]
INFO CoreConsole[2014-08-28 16:03:06] [a325b] Done archiving!


(Matthieu Aubry) #3

Check your server error log to find more info about the failure ?

Also setup the cron archiving: How to Set up Auto-Archiving of Your Reports - Analytics Platform - Matomo