Can't download GeoIP2 Database files

Just installed Matomo for Wordpress plugin and it looks really nice!
Also the performance of my hosted system seems almost as good as before (Website with only < 100 visits per day as of today).

I do have some minor issues, though, looking at the system status report, for example there seems to be errors in the log:

cron_sync 2019-12-30 10:05:41 Matomo is not set up yet => EnvironmentValidator.php:85; EnvironmentValidator.php:65; Environment.php:185; Environment.php:94; Bootstrap.php:74; Bootstrap.php:104; Sync.php:54; ScheduledTasks.php:167; class-wp-hook.php:286; class-wp-hook.php:312; plugin.php:544; wp-cron.php:138;
archive_main 2019-12-30 10:07:20 2 total errors during this script execution, please investigate and try and fix these errors. => CronArchive.php:594; CronArchive.php:587; CronArchive.php:326; Access.php:639; CronArchive.php:327; ScheduledTasks.php:216; class-wp-hook.php:286; class-wp-hook.php:312; plugin.php:544; wp-cron.php:138;

|archive_errors|2019-12-30 10:07:20|‘Got invalid response from API request: ?module=API&method=API.get&idSite=1&period=day&date=last2&format=php&trigger=archivephp. Response was ‘Got invalid response from API request: $site_url/wp-content/plugins/matomo/app?module=API&method=API.get&idSite=1&period=day&date=last2&format=php&trigger=archivephp&token_auth=TOKEN_REPLACED. Response was ‘Error while fetching data: cURL error 28: Operation timed out after 1000 milliseconds with 0 bytes received’’’ ‘Empty or invalid response ‘’ for website id 1, Time elapsed: 1.420s, skipping’ ‘2 total errors during this script execution, please investigate and try and fix these errors.’ => ScheduledTasks.php:229; class-wp-hook.php:286; class-wp-hook.php:312; plugin.php:544; wp-cron.php:138;|

|update_geoip2|2019-12-30 10:07:57|GeoIP2AutoUpdater: failed to unzip ‘$ABSPATH/wp-content/uploads/matomo/tmp/latest/GeoIP2-City.mmdb.tar.gz’ after downloading ‘’: Couldn’t list content for ‘$ABSPATH/wp-content/uploads/matomo/tmp/latest/GeoIP2-City.mmdb.tar.gz’: Invalid checksum for file “=1” /> Just a moment… html, body {width: 100%; height: 100%; margin: 0; padding: 0/ <meta http-equiv=“Content-Ty” : a http-e extracted => GeoIP2AutoUpdater.php:154; GeoIP2AutoUpdater.php:94; ScheduledTasks.php:152; class-wp-hook.php:286; class-wp-hook.php:312; plugin.php:544; wp-cron.php:138;|

Is this something to worry about? It would really be nice to get the city based IP localization up and running (the country seems to be ok), is there a way to restart the update process? I can’t find the settings for the IP look up as indicated in the on-premise version help.



For a change, this isn’t really a bug in Matomo, but something different.

You had a bit of a bad timing, because today MaxMind (the provider of the GeoIP databases) shut down their free download server (which causes this issue). (Announcment)

If you want to continue using Geolocation you can:

Lukas, thanks a alot for your fast answer, will look into these (and probably just wait…)!