Cannot use https to connect to Matomo

I can use http://x.x.x.x/ (a public IP) to connect to my Matomo, and I want to enable SSL.
Follow this FAQ, I try to use https://x.x.x.x/, but it refuses the connection.

I also use telnet to test, it still shows the connection is rejected.

ubuntu@server1:~$ telnet x.x.x.x 443
Trying x.x.x.x...
Connected to localhost.
Escape character is '^]'.
Connection closed by foreign host.

I try to enable assume_secure_protocol or force_ssl, but it doesn’t work.
Is there any suggestion?

I don’t use Apache or Nginx, is it possible to enable SSL without them?

So which kind of PHP server do you use on your Ubuntu?