Cannot update because of corrupt zip download

Hello, I haven’t been updating for a while. I don’t know the current version as there is no option in Piwik that would show this (feature suggestion?). I assume it’s something 1.5., 1.6 or so.
Now, when trying to use the self-update I get the exact same error that’s already been posted here: 301 Moved Permanently
The download of always ends with only 251 bytes.
When I download the file manually it gets overwritten, nevertheless. If I make it write-protected to apache it will complain about an error creating the file. So, it’s nonetheless downloading and trying to overwrite it.
How can I convince it to stop this? And why is this problem happening, anyway?

What exact error do you get with the download?

Not sure what you mean. I get the exact same error that is shown in the referenced article if I try to use the update option that is built into Piwik. That’s because it downloads only a 251 byte file. If I download the file myself and “plant it” (correct, uncorrupted file) in the right place Piwik nevertheless does a download and the result is the same as it overwrites the “good” file.

I think it’s 1.5, now, probably not 1.6. The update version would be 1.9.2. I see, the Download link on the forum has just changed to 1.10, but the “New Update” link in Piwik still shows 1.9.2 at the moment.

Ok, here is a clue. Out-of-the-blue I decided to do a “head” to see if it is at least the beginning a zip file or whatever. It’s a redirect page from your download server. It redirects from to The downloader doesn’t follow that 301 code.

I’ve changed that now in the two config files. I assume it should be working now. Should I upgrade now to 1.9.2 or wait until my setup knows about 1.10 (=tomorrow)?

Upgraded now (from 1.6 it seems) to 1.10. No problems.