Cannot login since latest upgrade


#1

Hi all,
Since the new upgrade I am no longer able to login to my piwik site.
I have reset the password from the login page, same result.
I have also followed the instructions on the site to reset the password through mysql, no dice.
I double checked and my config.ini.php is the same as before, correct DB entries.

I am running on nginx with varnish cache, have never had a problem previously like this.

Can anyone help?

thanks


#2

Hi everyone,

As soon as I posted this I managed to solve the problem.
I had to disable caching in WordPress and everything worked fine.
I didn’t realize that WordPress configs could effect Piwik.


(Matthieu Aubry) #3

WP config should not affect Piwik. I would be interesting to learn more, if you know why Caching broke Piwik… Maybe the .htaccess that got created by your WP cache, somehow conflicted with Piwik?


#4

Hi,
I am not having the issue now. but it seemed possible the old cache in my Wordpress was causing the issue. I use a plugin called W3 Total cache. when I disabled it, logins worked again.
I am using nginx, so no .htaccess per se. I have piwik as a subdirectory under the main-site www.mysite.com/PIWIK

Hope this helps a little.