Cannot install, get error


#1

This is a completely new install. I have not done it before. My problem is, I assume it is the problem, that the session is marked as read only. I’ve attached an image with the screen I get when I try to navigate to it. Including my URL (without the actual address for security reasons). My site is on a different port than 80. I am new to PHP so I have no clue what I am actually doing. Can anyone help me figure out what the problem actually is and how to fix it?


(vipsoft) #2

please try the 1.6 release candidate. 301 Moved Permanently


#3

I installed the 1.6 RC1 version. This is what I get. I still have no idea what it’s really saying.


(vipsoft) #4

It looks like the server-side session files can be created, but not modified. On Windows, this is expected if the ACL (access control list) doesn’t have the Modify permission granted. You’ll have to look in your system’s php.ini file (or look at the output of phpinfo()) to figure out where the session.save_path is. Make sure the ACL allows the web server pseudo-user has sufficient permisions (read, write, append, list directory, and delete)


#5

I modified the permissions for the folder where session.save_path is pointing to, to allow “full control” to everyone and I still get the exact same thing.


(vipsoft) #6

windows is wonky

make sure the acl includes read and list directory for parent directories

then clear your browser cookies and restart your browser – this should get you a new session


#7

Sadly, I still get the exact same thing. I’ve got the drive that my session.save_path is on permissions set to everyone has full control and I’ve taken ownership of the whole drive. Also, the folder with Piwik permissions set to everyone has full control, and I’ve also taken ownership of that folder as well. With my piwik folder permissions with everyone full control, with me as the owner. All subfolders and files have the exact same permissions, everyone full control with me as the owner. I’ve also deleted all of my browser cookies, history, passwords, and literally all of my temporary internet files. It’s still giving me the exact same error. Does anyone have anymore suggestions on how I could fix it? If not then. would it be possible to just zip up the files straight from the demo and give the zip folder to me? or a different site analytics program for me, one that’s free? Because I literally am at a complete loss here. I have absolutely no idea what else I could try without going into the actual coding and changing things. As I am new to PHP, that really wouldn’t be such a wise thing to do without any instructions on what to do or any help with it. And thank you very much for all of your help. I truly do appreciate it.


(Matthieu Aubry) #8

If you are new to PHP on Windows, I recommend you use XAMPP: XAMPP Installers and Downloads for Apache Friends

It is the easiest way to setup php/apache on windows


#9

I actually already have my webserver, “Xerver” and PHP installed and working. So I don’t want a program that will setup a webserver and PHP. Instead I want an Analytics program. So I can see all the details on who visits my site, how often they visit, and all that they do on my site. If Piwik isn’t that kind of program then I am sorry to have wasted your time.


(Matthieu Aubry) #10

the problem you experience here is a system configuration issue, not a Piwik issue. With XAMPP you will not have this issue.


#11

Ah, gotcha. I will check it out. Thank you for your time and also for the recommendation.


(Matthieu Aubry) #12

Alternatively, can you try make piwik/tmp/sessions/ writable ?


#13

It was already set to writeable. Xampp works. I believe the problem might have been the server I was using, “xerver” that was the problem.