Cannot access Piwik after update to 2.14


#1

About a month ago I was updating Piwik to 2.14.1, using automatic update using the update-link when being logged in.
I have always used this link and it has worked great every time, and I have always updated it to the latest version every time it arrives.

This time however, something went wrong at the end of the update process (the screen said the update was complete and then it jumped out of Piwik instead of sending me back to my ordinary overview seen when being logged in).

After this, when trying to access piwik via the ordinary login-page (index.php) the webaddress to index.php in the webbrowser is automatically relocated into mydomain/piwik/index.php?module=CoreUpdater&action=.

Then Firefox is presenting the following message on the screen (translated by me from swedish into english):

Coding error of the content.
The webpage cannot be shown since it uses a type of compression that is invalid or is not supported.

Since then I have read all topics in the forum for weeks now to find someone with a similar problem.

I have tried several times to update Piwik manually using FlashFXP (same software I used when initially instaliing Piwik in the first place about a year ago, and yes using binary mode), trying out both version 2.14.1 and 2.14.2 as well as the latest 2.14.3.

As your supportinfo says, I also re-installed the previously functioning backed-up config.ini-file without any luck (also sometimes tried re-installing the backed-up index-file).
Still, I get the very same webpage-relocation and Firefox message (using Explorer is no good either, which does not display the webpage, nor does it provide an error report) about the coding error.

It seems as if the first automatic 2.14.1 update written above is not yet completed, or perhaps have corrupted some file or something.

Do you have any suggestions on how to fix the problem?

All the best regards from an ohterwise very happy user of Piwik,

Anders


(Matthieu Aubry) #2

Hi there,

Feel free to try again installing with the latest 2.15.0 beta version which includes many fixes and improvements, see: I would like to test early beta and RC releases, how do I enable automatic updates to use these development versions? - Analytics Platform - Matomo

if you still have the problem, please create an issue on our issue tracker