Can´t install Piwik


(creartivo) #1

Hello,

i got a big problem with piwik. i downloaded and unzipped it. After that i uploaded it to my server in html-folder.
Now when i go to firefox and go to the adress mysite.de i become this error-message:

Warning: require_once(Zend/Session/Abstract.php) [function.require-once]: failed to open stream: No such file or directory in /var/www/web13/html/piwik/libs/Zend/Session.php on line 28

Fatal error: require_once() [function.require]: Failed opening required ‘Zend/Session/Abstract.php’ (include_path=’.’) in /var/www/web13/html/piwik/libs/Zend/Session.php on line 28

Please can someone help me??? Thank you all very much!


(oj.69) #2

[quote=creartivo @ Nov 14 2009, 12:59 PM]Hello,

i got a big problem with piwik. i downloaded and unzipped it. After that i uploaded it to my server in html-folder.
Now when i go to firefox and go to the adress mysite.de i become this error-message:

Warning: require_once(Zend/Session/Abstract.php) [function.require-once]: failed to open stream: No such file or directory in /var/www/web13/html/piwik/libs/Zend/Session.php on line 28

Fatal error: require_once() [function.require]: Failed opening required ‘Zend/Session/Abstract.php’ (include_path=’.’) in /var/www/web13/html/piwik/libs/Zend/Session.php on line 28

Please can someone help me??? Thank you all very much![/quote]
Hi there,

sounds to be a problem with your host. Please check with your host if you meet piwik´s minimal requirements.


(ozzie) #3

I had this same problem… has a solution been found yet?


(vipsoft) #4

The problem is that your host won’t allow Piwik to set the include path.

Ask your web host to set it for you (see index.php) or loosen the restriction.


(schelli) #5

Hello,

I have the same problem with the include_path, but it looks a bit different:

Warning: require_once(Zend/Session/Abstract.php) [function.require-once]: failed to open stream: No such file or directory in /var/www/vhosts/xxxxxx/httpdocs/piwik/libs/Zend/Session.php on line 28

Fatal error: require_once() [function.require]: Failed opening required ‘Zend/Session/Abstract.php’ (include_path=’.:/usr/share/php’) in /var/www/vhosts/xxxxxx/httpdocs/piwik/libs/Zend/Session.php on line 28

There is a path but I don’t no how it has to be correct.

Piwik worked fine for some month but now the issue occurred. I asked my provider that he had changed some things, I believe he done a update (plesk), but he said no. Now I have to figure out whats wrong or what he have to do now!!

Can someone tell me how I can check what my provider is blocking now?

Thank you.
Daniel


(hcl99) #6

I need a bit more help also is there a customer help line?


(schelli) #7

Ok, some more facts to that what I wrote.
I can contact my provider/hoster by e-mail only and they wrote all the time something like “you use that script, so when you have problems ask the developer for that issue”.
What I mean is, most of the time I have to prove, with facts, that this is a misconfiguration or what ever from the server, because it worked before. But I don’t how I can figure out this.

Some technical facts.
The server fulfils the minimum piwik requirement. The installation was possible without any problems before.
I use Piwik 0.5.4 and the server/webspace runs Plesk. I tried to install a complete new piwik 0.5.5 on the same webspace, same problem.
The file Abstract.php is definitely present at the server. I checked this by use the absolute path at line 28 at the Session.php file like this

/var/www/vhosts/xxxxxx/httpdocs/piwik/libs/Zend/Session/Abstract.php

One point to now for me is. How looked (include_path=’.:/usr/share/php’) before or what options at the phpinfo I have to check?
Thanks
Daniel


(vipsoft) #8

Tell your hosting provider to use php_value to set the PHP include path.

Piwik needs to set the include path so that Zend Framework files can be found.

Your hosting provider uses php_admin_value to set the PHP include path. As of PHP 5.2.5, this cannot be overridden by a php_value setting in your .htaccess file or by a PHP script, such as Piwik.


(schelli) #9

Hello,

thank you for this information.
I have given my hoster this information and will wait for response.

Thanks so lot
Daniel


(schelli) #10

Hello,
I have a response from my hoster and it was what I expect! Bla, bla only and no real information respectively the will to change somethings at the config. Even they don’t told me why they don’t allow this any longer. I believe they don’t now what they do, or simple update the servers straight forward.

So I think there is no chance for me at the moment to create the path.
As workaround for me, is it possible to set this path static?

Maybe with the next server update the include_path will work again, when the hoster does the next change wrong or whatever.

Otherwise I have to switch back to the google things style_emoticons/<#EMO_DIR#>/sad.gif

Daniel


(Karlsson) #11

Otherwise I have to switch back to the google things

Maybe you should switch to another hoster.


(vipsoft) #12

I’ve avoided doing this because it increases our software maintenance because a number of third-party libraries depend on the include path. However, since this is a common stumbling block, I’ve made changes to these libraries, so Piwik no longer needs to set the include path. This will be included in the upcoming 0.6 release.


(schelli) #13

[quote=vipsoft @ Apr 27 2010, 01:58 PM]…However, since this is a common stumbling block, I’ve made changes to these libraries, so Piwik no longer needs to set the include path. This will be included in the upcoming 0.6 release.[/quote]This sounds good for me. Definitely better then a endless sory with my hoster.

@Karlsson
To switch with all the data and scripts to another hoster is not that fun neither, that it sounds.

So, then I wait for the next release.
Thank you.
Daniel


#14

Hi, I have the same problem. I use hostgator. I copied and pasted your recommendation into a chat session. Here is what they came back with:

“Here is the issue I see Larry, Piwik’s index page is trying to link to /libs/upgradephp/upgrade.php which is turning into bargaintiger.com/piwik/libs/upgradephp/upgrade.php - which won’t happen, because that is not going to work. As for the php_value - I apologize but we would need more information before we can change this for you.”


(vipsoft) #15

That particular Hostgator support person is wrong. index.php constructs an absolute path, using the prefix PIWIK_INCLUDE_PATH.

The problem appears to be as the error message says, the piwik/libs/upgrade/upgrade.php file doesn’t exist. Probably missed when uploading the file from your desktop. FTP clients like Filezilla are problematic in this regard.