Can only see Visits in Real-time

Hello, first time user on this forum. I have loved Matomo as it has provided a secure and free alternative to Google analytics. However, ever since I have installed it I have not been able to see visits over time. I have only been able to see them in real-time. As a new user I guess I can only embed one media per post, so I merged all the screenshots of the errors I am getting into one image:

I really appreciate any help!


Can you check your webserver error log to see if there are more details about the errors there?

Also check your MySQL server as it seems like it disconnects when Matomo expects a response.

The tips from ( even though it is about a slightly different issue) might help here too.

Hi Lukas, thanks for the response. The error logs are empty. I am able to connect to the database as you can see by going to I am using Awardspace to host my websites, and I don’t think I am able to try what is suggested in the troubleshooting faq link you sent. However, Matomo was initially able to create the MySQL database and tables in my awardspace server, so it should be able to write to those tables too, right? I have been able to add another user and add a goal in my Matomo dashboard and I can see what I added in my MySQL database.

In fact, looking at my database it appears all the visits and actions done over time have been recorded. They are just having an error when they are attempted to be retrieved in the Matomo dashboard.

Update: changing adapter = PDO\MYSQL in my config/config.ini.php file as prescribed by lets me see number of visits over time. However there is still data missing that I don’t receive such as the Visitor Map saying “There is no data for this report” even though I am receiving locations of people in the Visits in Real-time section. Same exact problem for the other sections under the Visitors tab in the dashboard. I see the information in real-time but not over time.

Unfortunately I cannot set up a cron tab as suggested by

Is there a way to fix the “There is no data for this report.” message without doing that?


Make sure you have browser archiving enabled in the Matomo settings if you can’t use cron.

Yes sir. Had to wait, but now everything seems to be working. Thank you!

This post was flagged by the community and is temporarily hidden.