Can not see all websites dashboard (err:Row.php:346)


#1

Hi Good people @ Piwiki

Using Piwik for 2 years and no issues, totally awesome program. Last week just updated to new version and now I constantly get:

"API returned an error: Adding a subtable to the row, but it already has a subtable associated. at Row.php:346"
This happen each time I try to load all websites dashboard.

When I try to reach dashborad with all sites. I can still see individual stats and i can see all sites on my android phone, btu not on desktop - and THTA is the best screen with all sites nicely organised, so I really need this page back.
Please note I am not developer, so I need really details instructions on how to fix something.
Thanks a LOT.

Dean


(Matthieu Aubry) #2

could you try to setup this: How to Set up Auto-Archiving of Your Reports - Analytics Platform - Matomo

I think this may fix the issue!


#3

Hi Matt,

Thank you for suggestion. I tired that, but after 3 hours of running reports by cron, I still don’t have lck of seeing dashboard. Now, all I get is “Oops… problem during the request, please try again.”

Is there a way i can at least export my data and import in a new install of fresh Piwik. Or by your experience this will nto resolve issue at all.

Regards

Dean


(Matthieu Aubry) #4

Your data is not lost and is still tracked, so you can recover. I’m definitely here to help with this kind of issues to ensure we find good solution. In this case, what happened after you run cron for 3 hours? could you run it again and paste summary output ?

When you get “oops” error can you check your server error log and see what error is there?


#5

How did you upgrade was it download new and replace old or was it via the browser update?


#6

Hi Matt, i am sure data is saved, that;s why i was thinking maybe its easier to just put new Piwki and migrate data. I would guess that there will be some simple instructions. Sorry, i am not really technical person, so i’ll try to check server logs and post here.

Lesjokolat, it was upgrade through browser as i remember. upgrade was smooth, but after it could never see dashboard data again.page load, but no any data on any website, just ops thing.

cheers
Dean


#7

Hi Matt & other good people @ Piwik forum,

As mentioned before I am non-tech noob :slight_smile: So I just upgraded to 2.5.0 (from 2.4.1), through browser and all worked fine, including database upgrade. but my dashboard is still not visible (timeout = “Oops… there was a problem during the request.”). I sorted this by requesting to see only stats from yesterday. Than it was fine. I could finally see by dashboard - not as desired (i would like to see full 30 days stats), but it is something. Does this mean that my database is too big? Its 440MB. And I run piwik on VPS with 2GB RAM. Should I somehow clear some data to gain control of seeing all websites dashboard? I have stats for about year. I don’t mind if this is cut down to 6 months. Please let me know.

Thanks a lot. Regards

Dean


(Matthieu Aubry) #8

timeout = “Oops… there was a problem during the request.”

Check in your server error log file, do you see an error there?


#9

Maybe up the memmory setting of your php.ini. if posible double it.