Can I change the 30 second db timeout?


(BP77) #1

I have a 0.9 install on an older machine that keeps hitting the timeout limit when I try and access data from busier time periods. The specific error I get is:

Fatal error: Maximum execution time of 30 seconds exceeded in C:\wamp\www\piwik\libs\Zend\Db\Statement\Pdo.php

I have run the archive script on this data already and turned off archiving in the browser. These are older reports that I don’t run often so I’d rather increase the timeout than move it to a faster machine. Is there any way for me to adjust the timeout setting?


(Matthieu Aubry) #2

http://piwik.org/faq/troubleshooting/#faq_103


(BP77) #3

Thanks!