Call to undefined method Piwik\Updater::addComponentToCheck()


#1

Hello !

I’m posting here because after an automatic update from 2.10.0 to 2.12 I am now having the following error :


Fatal error: Call to undefined method Piwik\Updater::addComponentToCheck() in /homepages/16/d410276458/htdocs/piwik/plugins/CoreUpdater/CoreUpdater.php on line 131

Fatal error: Uncaught exception 'Zend_Session_Exception' with message 'Session must be started before any output has been sent to the browser; output started in /homepages/16/d410276458/htdocs/piwik/plugins/CoreUpdater/CoreUpdater.php/131' in /homepages/16/d410276458/htdocs/piwik/libs/Zend/Session.php:443 Stack trace: #0 /homepages/16/d410276458/htdocs/piwik/libs/Zend/Session/Namespace.php(143): Zend_Session::start(true) #1 /homepages/16/d410276458/htdocs/piwik/core/Session/SessionNamespace.php(34): Zend_Session_Namespace->__construct('CorePluginsAdmi...', false) #2 /homepages/16/d410276458/htdocs/piwik/core/Nonce.php(39): Piwik\Session\SessionNamespace->__construct('CorePluginsAdmi...') #3 /homepages/16/d410276458/htdocs/piwik/plugins/CorePluginsAdmin/Controller.php(364): Piwik\Nonce::getNonce('CorePluginsAdmi...') #4 [internal function]: Piwik\Plugins\CorePluginsAdmin\Controller->safemode(Array) #5 /homepages/16/d410276458/htdocs/piwik/core/FrontController.php(530): call_user_func_array(Array, Array) #6 /homepages/16/d4 in /homepages/16/d410276458/htdocs/piwik/libs/Zend/Session.php on line 443

I have found these 2 similar errors :

In those posts the solution is to manually update Piwik, so obviously that’s what I did via SSH commands :


# go into the the directory that contains your existing "piwik/" installation 
$ wget http://builds.piwik.org/piwik.zip # download latest version
$ unzip -o piwik.zip # extract it to "piwik/" directory
$ rm piwik.zip # delete the archive and read below the next step

But it doesn’t work at all and the same error message appears :confused:
I also tried to put back the 2.10.0 piwik files in my folder and the problem still is the same.
In my database the piwik version is 2.10.0

I hope you could help me find a solution as I would prefer not lose all my data and make a clean install :slight_smile:

Best regards,
Yann


(Matthieu Aubry) #2

Hi Yann

don’t worry about losing data: with Piwik you never have to lose your data (as long as you have a backup etc.)

For this error can you try chmod 777 -R path/piwik/tmp and try again ?


#3

Hi Matt,

Thank you for responding.

I tried adding those permissions to the tmp folder with your command but it doesn’t change anything to my problem.

Yann


(Matthieu Aubry) #4

we just release 2.13.0 release candidate, maybe that one would work better for you? http://builds.piwik.org/


#5

I have downloaded the “piwik-2.13.0-rc1.zip” file and unzipped it in my piwik folder, and I still get the same error message when I go to my piwik homepage :confused:


(Matthieu Aubry) #6

Hi there,

Ok then it must be a bug somewhere - do you mind creating an issue in Issues · matomo-org/piwik · GitHub ?


#7

No problem, I created the issue, it’s available here : Call to undefined method Piwik\Updater::addComponentToCheck() · Issue #7753 · matomo-org/piwik · GitHub

Thanks !


#8

Hi,

I used SSH again to get the last piwik version and unzip it in my piwik folder and the error still appeared. So I checked the number of lines of the CoreUpdater.php file and there was a delta between my file and the original file downloaded… Apparently the unzip command via SSH, even with -o parameter, doesn’t overwrite very well the files.

I uploaded the latest piwik version manually using FTP and now it works !

Problem solved, thank you !