Bug: "Warning: require_once(): Unable to allocate memory for pool"


#1

I got this error msg when browsing the piwik console, every page is like this. rebooting httpd/apache2 fixes this temporarily.

a full pdf printout of the error page is attached. below is a shorter excerpt of the msg

############################################################

There is an error. Please report the message (Piwik 2.4.1) and full backtrace in the Piwik forums (please do a Search first as it might have been reported already!).

Warning: require_once(): Unable to allocate memory for pool. in /var/www/html/piwik/core/Loader.php on line 98

Backtrace -->

#0 Piwik\Error::errorHandler(…) called at [/var/www/html/piwik/core/Loader.php:98]
#1 Piwik\Loader::tryToLoadClass(…) called at [/var/www/html/piwik/core/Loader.php:98]
#2 Piwik\Loader::tryToLoadClass(…) called at [/var/www/html/piwik/core/Loader.php:84]
#3 Piwik\Loader::loadClass(…) called at [/var/www/html/piwik/core/Loader.php:114]
#4 Piwik\Loader::autoload(…) called at [:]
#5 spl_autoload_call(…) called at [/var/www/html/piwik/core/Singleton.php:37]
#6 Piwik\Singleton::getInstance(…) called at [/var/www/html/piwik/plugins/Events/Widgets.php:19]
#7 Piwik\Plugins\Events\Widgets->configure(…) called at [/var/www/html/piwik/core/WidgetsList.php:87]
#8 Piwik\WidgetsList::addWidgets(…) called at [/var/www/html/piwik/core/WidgetsList.php:57]
#9 Piwik\WidgetsList::get(…) called at [/var/www/html/piwik/plugins/Dashboard/Controller.php:42]
#10 Piwik\Plugins\Dashboard\Controller->_getDashboardView(…) called at [/var/www/html/piwik/plugins/Dashboard/Controller.php:56]
#11 Piwik\Plugins\Dashboard\Controller->embeddedIndex(…) called at [:]
#12 call_user_func_array(…) called at [/var/www/html/piwik/core/FrontController.php:531]
#13 Piwik\FrontController->doDispatch(…) called at [/var/www/html/piwik/core/FrontController.php:84]
#14 Piwik\FrontController->dispatch(…) called at [/var/www/html/piwik/core/dispatch.php:34]
#15 require_once(…) called at [/var/www/html/piwik/index.php:47]


#2

error print out


#3

did you check your php.ini mempery setting? Maybe try and increase it to double what its set to now.


(Matthieu Aubry) #4

please try with latest 2.6.0-rc1 where this should be fixed. Index of /


#5

thanks guys, I did the following:

  1. update to latest (2.6.1)
  2. update this line to /etc/php.ini
    memory_limit = 1128M
  3. add this line to /etc/php.ini
    apc.mmap_file_mask=/apc.shm.XXXXXX

still have the same problem


#6

http://forum.piwik.org/read.php?2,118423,page=1#msg-119789

check out this post as it may b
help you.


#7

thanks, I checked. my httpd.conf doesn’t have settings for rlimit