[BUG REPORT] Fehlermeldung im PIWIK


#1

Guten Morgen

Gerade habe ich bemerkt, dass PIWIK mir unter Dashboard -> (Widget) Piwik.org Blog einen Fehler anzeigt:


There is an error. Please report the message (Piwik 1.12) and full backtrace in the Piwik forums (please do a Search first as it might have been reported already!).

Deprecated: iconv_set_encoding(): Use of iconv.internal_encoding is deprecated in /mnt/webn/e0/85/[b]XXXXX[/b]/htdocs/Piwik/libs/Zend/Validate/Hostname.php on line 549 

Backtrace -->

#0 Piwik_ErrorHandler(...) called at [:]
#1 iconv_set_encoding(...) called at [/mnt/webn/e0/85/[b]XXXXXX[/b]/htdocs/Piwik/libs/Zend/Validate/Hostname.php:549]
#2 Zend_Validate_Hostname->isValid(...) called at [/mnt/webn/e0/85/[b]XXXXXX[/b]/htdocs/Piwik/libs/Zend/Uri/Http.php:445]
#3 Zend_Uri_Http->validateHost(...) called at [/mnt/webn/e0/85/[b]XXXXXX[/b]/htdocs/Piwik/libs/Zend/Uri/Http.php:277]
#4 Zend_Uri_Http->valid(...) called at [/mnt/webn/e0/85/[b]XXXXXX[/b]/htdocs/Piwik/libs/Zend/Uri/Http.php:154]
#5 Zend_Uri_Http->__construct(...) called at [/mnt/webn/e0/85/[b]XXXXXX[/b]/htdocs/Piwik/libs/Zend/Uri.php:145]
#6 Zend_Uri::factory(...) called at [/mnt/webn/e0/85/[b]XXXXXX[/b]/htdocs/Piwik/libs/Zend/Http/Client.php:305]
#7 Zend_Http_Client->setUri(...) called at [/mnt/webn/e0/85/[b]XXXXXX[/b]/htdocs/Piwik/libs/Zend/Feed.php:170]
#8 Zend_Feed::import(...) called at [/mnt/webn/e0/85/[b]XXXXXX[/b]/htdocs/Piwik/plugins/ExampleRssWidget/Rss.php:46]
#9 Piwik_ExampleRssWidget_Rss->get(...) called at [/mnt/webn/e0/85/[b]XXXXXX[/b]/htdocs/Piwik/plugins/ExampleRssWidget/Controller.php:23]
#10 Piwik_ExampleRssWidget_Controller->rssPiwik(...) called at [:]
#11 call_user_func_array(...) called at [/mnt/webn/e0/85/[b]XXXXXX[/b]/htdocs/Piwik/core/FrontController.php:125]
#12 Piwik_FrontController->dispatch(...) called at [/mnt/webn/e0/85/[b]XXXXXX[/b]/htdocs/Piwik/index.php:47]

Was ist das?

VG
BCIX


(Stefan Giehl) #2

Das ist ein Warnhinweis von PHP über die Verwendung einer veralteten Funktion.
Welche Version von PHP hast du denn auf dem Server installiert?
In der Fehlermeldung steht, dass du noch Piwik 1.12 benutzt.
Aktuell ist bereits 2.13. Besteht keine Möglichkeit Piwik zu aktualisieren.


#3

Hallo SteveG,

Vielen Dank für deine Antwort!
Leider geht das mit dem aktualisieren nicht, siehe:

http://forum.piwik.org/read.php?5,127056

Shit. X(

VG
BC(I)X