Bug Cron since update 3. 9. 1


(thomas Müller) #1

Hello, everyone,

I’ve made a mistake since the last update.
Does anyone have any idea how I can fix this?

memory_limit 512 MB
Isn’t that enough? I have only 25 pages with little traffic.

ERROR [2019-03-25 00:11:21] 30462 Got invalid response from API request: ?module=API&method=API.get&idSite=13&period=year&date=last2&format=php&trigger=archivephp. The response was empty. This usually means a server error. A solution to this error is generally to increase the value of ‘memory_limit’ in your php.ini file. For more information and the error message please check in your PHP CLI error log file. As this core:archive command triggers PHP processes over the CLI, you can find where PHP CLI logs are stored by running this command: php -i | grep error_log
ERROR [2019-03-25 00:11:45] 30462 Got invalid response from API request: ?module=API&method=API.get&idSite=14&period=week&date=last2&format=php&trigger=archivephp. The response was empty. This usually means a server error. A solution to this error is generally to increase the value of ‘memory_limit’ in your php.ini file. For more information and the error message please check in your PHP CLI error log file. As this core:archive command triggers PHP processes over the CLI, you can find where PHP CLI logs are stored by running this command: php -i | grep error_log
ERROR [2019-03-25 00:17:49] 30462 Got invalid response from API request: ?module=API&method=API.get&idSite=21&period=year&date=last2&format=php&trigger=archivephp. The response was empty. This usually means a server error. A solution to this error is generally to increase the value of ‘memory_limit’ in your php.ini file. For more information and the error message please check in your PHP CLI error log file. As this core:archive command triggers PHP processes over the CLI, you can find where PHP CLI logs are stored by running this command: php -i | grep error_log
ERROR [2019-03-25 00:36:57] 30462 3 total errors during this script execution, please investigate and try and fix these errors.
[Exception]
3 total errors during this script execution, please investigate and try and fix these errors.
core:archive [–url="…"] [–force-all-websites] [–force-all-periods[="…"]] [–force-timeout-for-periods[="…"]] [–skip-idsites[="…"]] [–skip-all-segments] [–force-idsites[="…"]] [–force-periods[="…"]] [–force-date-last-n="…"] [–force-date-range[="…"]] [–force-idsegments="…"] [–concurrent-requests-per-website[="…"]] [–concurrent-archivers[="…"]] [–disable-scheduled-tasks] [–accept-invalid-ssl-certificate] [–php-cli-options[="…"]]


(Fabian Dellwing) #2

512MB is more than enough for your setup. Please take a look at your PHP error log for a better error message.


(thomas Müller) #3

there is nothing in the error log. I looked it up several times. The cron job runs every night and generates the error.