Bug after upgrade


(frager) #1

After upgrading 0.2.34 to 0.2.35 I get the following error from apache in my syslog:

May 14 22:17:24 myserver kernel: apache2[9767]: segfault at 00007fffd19e3ff8 rip 00002b4fdf3dafb3 rsp 00007fffd19e4000 error 6
May 14 22:17:31 myserver kernel: apache2[9762]: segfault at 00007fffd19e3ff8 rip 00002b4fdf3dafb3 rsp 00007fffd19e4000 error 6
May 14 22:17:31 myserver kernel: apache2[9787]: segfault at 00007fffd19e3ff8 rip 00002b4fdf3dafb3 rsp 00007fffd19e4000 error 6
May 14 22:17:31 myserver kernel: apache2[9772]: segfault at 00007fffd19e3ff8 rip 00002b4fdf3dafb3 rsp 00007fffd19e4000 error 6
May 14 22:17:32 myserver kernel: apache2[9788]: segfault at 00007fffd19e3ff8 rip 00002b4fdf3dafb3 rsp 00007fffd19e4000 error 6
Bug or wrong settings in my configs?


(vipsoft) #2

Can you check Apache’s error.log ?


(frager) #3

I updated to .37 now but get the same error. My error.log ist not more useful…

[Sun May 17 20:46:50 2009] [notice] child pid 4681 exit signal Segmentation fault (11)
 31 [Sun May 17 20:46:58 2009] [notice] child pid 4560 exit signal Segmentation fault (11)
 32 [Sun May 17 20:46:58 2009] [notice] child pid 4682 exit signal Segmentation fault (11)
 33 [Sun May 17 20:46:59 2009] [notice] child pid 4563 exit signal Segmentation fault (11)
 34 [Sun May 17 20:46:59 2009] [notice] child pid 4565 exit signal Segmentation fault (11)

Could that be due to a to small memory amount for mysqld or apache? I’m running my server under minimal conditions… any help would be appreciated :slight_smile:


(vipsoft) #4

it could be your php memory limit. undersized hardware isn’t going to work in the long run.

try disabling archiving in the browser and use a cron job instead ( php cli typically has no mem limit)


(frager) #5

I increased memory_limit from 20MB to 25MB. But still doesn’t change anything. It’s also strange that I never got this error before but now after updating frist to .36 and then to .37…
I’m setting up cronjob now and let’s see what happens…


(vipsoft) #6

25MB is small; I think the default on my php installation is 125MB

If you’re running Centos or Fedora, you might try the MALLOC_CHECK workaround.


(Matthieu Aubry) #7

also simplest solution would be to update your php version, this is most likely a bug in an old php release.


(frager) #8

Interestingly the problem disappered with version 0.4.1… Dunno if it was due to a bug and is solved now or just coincidence :wink: Strange that I seemed to be the only one with this problem…