Blank Page in Admin + thousands of Forbidden


#1

Just a fresh install on Ubuntu 16.04
It’s a VPS at dreamhost with Let’s encrypt, PHP 7.1 FastCGI, MySQL (i don’t know the version)
and i did the install via SSH wget https://builds.piwik.org/piwik.zip && unzip piwik.zip
during the test ALL was green, i have chosen MYSQLI (as i use it)
at the end Matomo asked me to update the table => OK done, no error
etc… all was flawless (great interface to install Matomo BTW)
then I log in
then after I got that I did not have visitors OK
I go to the settings and …

A blank page appears where i can only see the top menu black-bar with Matomo written and the left menu.

Also everywhere I click on the menu, I got nothing, just a blank page (except the top menu and the left menu which are showing up)
but it is not only that, the server sent me thousands of emails about an Error 403 (Forbidden) :
REQUEST_URI : /analyses/piwik/plugins/CoreHome/angularjs/notification/notification.directive.php?cb=485ab7a1977fccff9409e9245f16cde4

Any ideas?


(Fabian Dellwing) #2

Do you probably use apache with mod_security enabled?


#3

Sorry for the delay of my answer, I was out yesterday

Indeed, yes! (wow you pinpoint it!)
Matomo is hosted on the same www dot domain dot name, though.

Does it mean I cannot use Matomo? Or is there a workaround to work with mod_security enabled
Or do I really need to disable the mod_security?


(Fabian Dellwing) #4

It is possible to use it with mod_sec enabled. But you will probably have to tweak a lot of things, because not only does the backend break but the tracking also.

With default configs you are unable to use Matomo.

See: How do I configure Piwik when mod_security (or CA SiteMinder) is enabled? - Analytics Platform - Matomo


#5

@fdellwing Thanks a lot for your answer.


#6

I found a solution which is working very nicely!

I created a subdomain like analitics.example.com where I put Matomo/Piwik with the mod_security disabled and it works like a charm to monitor the main domain where mod_security is enabled.


(Lukas Winkler) #7

Hi,

Great you found a solution. Putting Matomo on a seperate subdomain is always cleaner as it also makes sure the htaccess of the main site doesn’t interfere.