Bitte geben Sie einen Wert für 'idSite' an


#1

Hallo Zusammen,

habe jetzt vergeblich in allen Foren gesucht, daher hier meine Bitte um Hilfe. Wir setzen Piwik jetzt seit Jahren ein, ich habe aber selbst nur ganz rudimentäre Grundkenntnisse in php. Alle updates von Piwik werden über die automatische Upate Funktion durchgeführt.

Der heutige Versuche eine weitere Seite zum Dashboad aller Webseiten hinzuzufügen führte zur im Betreff genannten Fehlermeldung. Eine neue Seite konnte ich nicht hinzufügen.

Im Dashboard : EInstellungen funktioniert zunächst alles, aber auch dort wird mit dem o.g. Fehler abgebrochen, wenn ich das Untermenu Webseiten aufrufen möchte. Stattdessen wird eine fragmentierte Version der homepage angezeigt unter der Piwik installiert ist. Screenshot anbei.

Die index.php von Piwik ist per htaccess abgesichert. Die Aufhebung der Absicherung durch Löschung der htaccess brachte nichts.

Der Versuch über einen separaten Browser brachte ebenfalls nichts.

Die Löschung aller Dateien im tmp Verz. gemäß Hinweis in Piwik troubleshooting änderte auch nichts.

In den Suchmaschinen fand ich einen Hinweis auf Änderungen in der htaccess Datei die Wordpress vornimmt. Die Seite ist jedoch komplett in html progammiert. Wordpress wird nicht eingesetzt.

Hat jemand eventuell eine Idee? Danke vorab für jeden hilfreichen Hinweis.

Dirk


(Stefan Giehl) #2

Welche Version von Piwik habt ihr denn aktuell im Einsatz?
Möglichweise ist heir auch etwas bei einem Update schiefgelaufen. In diesem Fall könnte es helfen, die Dateien von Piwik nochmals manuell auf den Server zu schieben.


#3

Hi, Danke für deine Antwort. Der Fehler bestand bei der 2.9.1 final. Eventuell schon vorher, da wir seit der letzten Version noch keine neue Seite zugefügt hatten. Nachdem nichts half hab ich gestern von 2.9.1 auf die aktuellste Beta 2.10.b9 RC glaube ich - updated - keine Veränderung. Alle downloads bisher liefen per automatischer Prozedur. Ich möchte das Problem nicht noch vergrößern - daher macht mich der Gedanke eines erneuten uploads etwas nervös zumal das von gestern auch keine Hilfe brachte.


(Stefan Giehl) #4

Kannst du in deinem Browesr mal nachsehen ob hier ein JavaScript Fehler auftritt?
Welchen Browser setzt du ein? Bzw. hast du es auch schon einmal mit einem anderen Browser probiert?


#5

Firefox in der aktuellsten Version. Alternativ IE und Chrome ausprobiert. Keine Veränderung. Heut nochmal manuell alles hochgeladen, keine Veränderung, Danach auto update auf 2.10 RC1 - Fehler bleibt. Der neue screenshot anbei.
Alles weitere scheint zu funktionieren. Ich kann aber keine neue Seite hinzufügen. Danke für deine Mühe bisher.


(Stefan Giehl) #6

Hm. Da bin ich nu ehrlich gesagt spontan auch überfragt. Müsste mir das mal näher ansehen.

Könntest du mir zur Diagnose mal Zugriff auf dein Piwik geben?
Falls ja schick die Zugangsdaten bitte an stefan@piwik.org


#7

@Stefan - Hi, das kann ich leider nicht tun.Sorry und bitte um Verständnis. Ein weiteres Merkmal ist, dass das Domainalter auch immer falsch angezeigt wird. Es rechnet scheinbar ab jedem update neu von null.

Die Aufrufe der Einstellung funktionieren aus dem Menu einwandfrei. Wenn man allerdings versucht eine Seite hinzuzufügen, den Fehler also reproduziert und dann weitere Einstellungen aufruft tritt auch dort die Fehlermeldung auf.

Der Aufruf des Moduls SitesManager: /piwik/index.php?module=SitesManager&action=index&idSite=1&period=day&date=today führt zum Fehler.
An einer fehlenden Berechtigung für diese php Datei kann es nach m Meinung auch nicht liegen, die wurden seit erster Installation nie verändert.

Könnte es sein, das ein falscher Pfad übergeben wird und statt dessen dann nur die index Seite des Hauptverzeichnisses angezeigt wird? (www.landways.de/index.html oder …/ statt dem ganzen Pfad zur Sitemanager.php)?

Die Aufrufe aller weiteren Module funktioniert problemlos. Deaktivieren von plugins wie Counter oder Barometer bringt keinerlei Änderung.

Danke für deine Hilfe.
dirk


(Stefan Giehl) #8

Kein Problem. Hab ich auch Verständnis für…
Das mit dem Domainalter ist keine wirklich verlässliche Angabe. Das Problem ist, dass die Daten aus dem Whois-Eintrag geparsed werden. Je nach Rückgabe steht hier das Datum der Erstellung oder das der letzten Änderung drinnen.

Hast du für Piwik irgendwelche besonderen Einstellungen im Apache oder Rewrites o.ä. in einer .htaccess oder so?


#9

Soweit ich weiß keine besonderen Einstellungen für Piwik. ich kopiere mal die Teile aus den htaccess dateien. Das meiste ist auskommentiert und rewrites müssten sich nach meinem Verständnis auf alles auswrirken - aber da kenne ich mich nicht gut genug aus.

  1. im root verzeichnis:

.htaccess-Datei für Web-Verzeichnis /

Options -Indexes
RewriteEngine On
RewriteCond %{THE_REQUEST} index.html
RewriteRule ^(.)index.html http://www.landways.de [L,R=301]
RewriteCond %{HTTP_HOST} ^landways.de
RewriteRule (.
) http://www.landways.de/$1 [R=301,L]

#LogLevel debug
#
#GeoIPEnable On
#GeoIPDBFile /var/www/piwik/plugins/GeoIP/libs/GeoLiteCity.dat
#

############################################

enable apache served files compression

Best Practices for Speeding Up Your Web Site - Yahoo Developer Network

# Insert filter on all content
###SetOutputFilter DEFLATE
# Insert filter on selected content types only
AddOutputFilterByType DEFLATE text/html text/plain text/xml text/css text/javascript

# Netscape 4.x has some problems...
BrowserMatch ^Mozilla/4 gzip-only-text/html

# Netscape 4.06-4.08 have some more problems
BrowserMatch ^Mozilla/4\.0[678] no-gzip

# MSIE masquerades as Netscape, but it is fine
BrowserMatch \bMSIE !no-gzip !gzip-only-text/html

# Don't compress images
SetEnvIfNoCase Request_URI \.(?:gif|jpe?g|png)$ no-gzip dont-vary

# Make sure proxies don't deliver the wrong content
Header append Vary User-Agent env=!dont-vary

neu um wc3 zu validieren

<FilesMatch “.(html|php)$”>

BrowserMatch MSIE ie
Header set X-UA-Compatible “IE=Edge,chrome=1” env=ie

#neu um http requests zu minimieren
#

Enable expirations

##ExpiresActive On

Default directive

##ExpiresDefault “access plus 1 month”

My favicon

##ExpiresByType image/x-icon "access plus 1 year”

Images

##ExpiresByType image/gif “access plus 1 month”
##ExpiresByType image/png “access plus 1 month”
##ExpiresByType image/jpg “access plus 1 month”
##ExpiresByType image/jpeg “access plus 1 month”

CSS

##ExpiresByType text/css "access 1 month”

Javascript

##ExpiresByType application/javascript “access plus 1 month”

#

#
#AddType application/x-httpd-php .html
#AddType application/x-httpd-php .htm
AddType video/webm .webm
#AddHandler fcgid-script .html
#AddHandler fcgid-script .htm
#AddHandler fcgid-script .php

#FCGIWrapper /var/www/php-fcgi-scripts/dnagel/landway.de/php-fcgi-starter .html
#FCGIWrapper /var/www/php-fcgi-scripts/dnagel/landway.de/php-fcgi-starter .htm
#FCGIWrapper /var/www/php-fcgi-scripts/dnagel/landway.de/php-fcgi-starter .php
#Options +ExecCGI
#

ErrorDocument 404 /html/404Fehlerseite.html

ErrorDocument 401 Unauthorized

ErrorDocument 403 Forbidden

ErrorDocument 410 Gone

ErrorDocument 500 Internal Server Error

  1. Im piwik verzeichnis:

AuthUserFile /####################/piwik/#########
AuthGroupFile /dev/null
AuthName "#########"
AuthType Basic

require valid-user

Options -Indexes


#10

update auf die neue RC 3 hat auch nichts geändert.


(Stefan Giehl) #11

Das Problem liegt wohl an den Apache Einstellungen…

Der SiteManager versucht folgende Datei per Ajax nachzuladen: /plugins/SitesManager/templates/index.html

Die Rewrite-Regel könnte hier Probleme machen:


RewriteCond %{THE_REQUEST} index\.html 
RewriteRule ^(.*)index\.html http://www.landways.de [L,R=301]

Möglicherweise könnte es Abhilfe schaffen hier eine zusätzliche RewriteCond einzubauen die den Piwik-Unterordner hiervon ausschließt.
Sowas wie:


RewriteCond %{REQUEST_URI} !^/piwik

Versuch mal http://www.landways.de/piwik/plugins/SitesManager/templates/index.html aufzurufen, Hier wird direkt ein Redirect gemacht. Sobald dieser weg ist, sollte alles wieder gehen…


#12

@Stefan - Problem gelöst. Vielen vielen Dank.

Es war dein Tipp mit den rewrite conditions. Vielen Dank für deine Hilfe. Das war das erste Mal das ich in einem Forum etwas gepostet habe und ich habe diese Unterstützung nicht erwartet. Das ist toll und macht Hoffnung.

Auch wenn es eventuell unüblich sein sollte - ganz herzlichen Dank, dass du dir die Zeit genommen hast zu helfen. Wir unterstützen die Piwik Idee weiterhin auch mit donations und solltest du mal Offroad fahren wollen - melde dich bei mir. :slight_smile:

Einen guten Rutsch und viel Erfolg für 2015.

Now we can keep on tracking…

Herzlichen Gruß
Dirk