Average Generation Time Missing


#1

Hello Guys,

Thank you for the job to the Piwik Team, we find the tool very useful.
We have activated Piwik 2.6.2 for full java Java Web applications using standard JSP and while we go the page menu the avaerage generation time is missing for almost all the page displayed. Just a “-” is displayed on screen.
I wonder if there is something I missed during configuration on the client side.
I use JS tracker and just set page title variable, nothing more.

I’ve noticed that for the few pages which the average generation time is displayed, the number of hits used to calculate the generation time is very low comparing to the number of pageview. Most of the number of hits is about 1-3 hits while the corresponding number of pageview is about 50-100.


(Matthieu Aubry) #2

Please upgrade ASAP to latest stable version as there were many bug fixes including critical security fixes


#3

Hello Matt,

Thank you for your answser. I’ll do that rightnow.

JB.


#4

Hello Matt,

I’ve upgraded to the latest version 2.9.1 but it seems that the problem remains.
Almost all “average generation time” values are missing. On the few pages with the “average generation time” displayed, the number of hits used to calculate the generation time is very low comparing to the number of pageview. Most of the number of hits is about 1-3 hits while the corresponding number of pageview is about 50-100.

Is there something to do on the client side in js ?

Cause Web Applications and Piwik are in a professional infrastructure, firewall and others proxies may disturb the calculation of page generation time ?

Many thanks for your help.

JBP.


(Matthieu Aubry) #5

Hi JBP,

Maybe your users are all using a particular browser such as old version of IE or other, that would not include the Timing feature? Piwik tracks the avg generation time using information given by the browser.


#6

Hi Matt,

Indeed, it seems that the Timing feature does not work with IE8.

Is there a patch forcasted for this feature in a next version of Piwik or a workaround in the tracker client to force IE8 to send Timing infos to Piwik server ?

Thanks a lot for your help,

JBP.