Automatic email pdf report not working


(Bretweb) #1

Hi
Piwik is installed on 1and1 server …

I have set to send reports automaticly but nothing happen …

Can somebody help me to set the email server for 1and1 on piwik

Regards


(Karsten Krohn) #2

Same issue here with 1und1. Tested with Piwik 1.1.1, Piwik 1.2-RC5, Piwik 1.2.
Manual mail of report is working, automatic mails are not sent.
I set archiving to “yes”, and Processing to “3600” secs (It’s a low traffic blog plus I have no access to cron.d)
I set send-mail through mail().

Is there a way to trace/log the process and a way to trigger it? I’m not familiar with ZendFramework, but I’m ok with PHP…


(pista73.com) #3

Been using Piwik over a year and since this plugin was launched was never able to receive pdf in my mail.

If send report is clicked, system will send the pdf report but never received the file sent through cron job.

Is there anything I could do to debug and check where is the problem?
Or should I report to the hosting company?

Thanks


(Matthieu Aubry) #4

Unfortunately there is not much logging available right now, I created a ticket so we improve it to be able to debug your issue: Automatic PDF email report not working when PDF report is linked to deleted site · Issue #2155 · matomo-org/matomo · GitHub


(pista73.com) #5

It would be great!
Already trying with SMTP and mail() and no luck :frowning:

To be honest I bet it may be something linked with the hosting server.
When I installed Piwik, it was not counting and I had to ask to white list it in mod_security.


(vipsoft) #6

Check with the hosting provider re: the mail host, port, login, password, and authentication type.

For example, on HostGator, you have to set the port to 26 (rather than the standard SMTP port 25).


(pista73.com) #7

In fact it is Hostgator. Seems more people is having trouble with them due mod_security… :S

Scenario:
Hosting: Hostgator
Mail: Using MX with Google.

Already tried both options to receive the pdf report: mail() and SMTP with gmail.

I am thinking they might block mail() and gmail in cronjobs because I had other problem in their servers with other script using mail pipe. Going to contact them and then will share here.


(Karsten Krohn) #8

If it is a hosting thing:
If have problems on both: An installation at 1und1 and an installation on a self hosted server.
Problem is: automatic mails do not even hit the mail server.
That is why I asked for more logging and a way to trigger the automatic process. Looks like I can not analyse the problem with what I have with 1.2, but I guess the cron script is not doing anything.

Sorry for bad English, not my native language.


(Bretweb) #9

Hi
Impossible to send an email on 1an1 hosting set with standard php or with a specific account — I have tried all possibility :sunglasses:

the system answer connexion refused … I don’t understand why …

I have many web site hosted here without problem …

Please somebody can tell me if it’s obliged to set a cron task to send automatic reports ? …
thanks


(Bretweb) #10

Hi
always trying to set my email to send reports on 1and1.fr host :

no ssl is set but always the same answer is:

Error was ’ is unsupported SSL type’

where is the problem ??


(pista73.com) #11

you may try ssl://auth.smtp.1and1.fr


(Bretweb) #12

Hi thanks

I will try

but normaly ther is no ssl on 1and1 host


(Bretweb) #13

answer here
An error occured while sending ‘PDF Report - 4.2011-02-28.1.fr.pdf’ to ecrire@bretweb.net. Error was ''ssl://auth.smtp.1and1.fr ’ appears to be a DNS hostname but cannot match TLD against known list, ‘ssl://auth.smtp.1and1.fr ’ does not appear to be a valid local network name’


(bolero) #14

''ssl://auth.smtp.1and1.fr" is not a hostname, you can’t use it. Search this forum for some older postings from this year about this problem. There is a known bug with the automatic sending and the fix should be in 1.2, compare Reports do not send whilst set to a daily basis · Issue #1961 · matomo-org/matomo · GitHub


(bolero) #15

If you cannot even send manually then the problem is likely not in Piwik. If you have shell access then check the maillogs. If you don’t have shell access then do not send the report externally before you know it works basically, e.g. send it to your local email account on that server before you try anything else! One step at a time!


(vipsoft) #16

Things to check:

  • is php4 the default? If you’re using the .htaccess file trick to use php5, this file is only read by Apache using mod_php. For cron (using php-cli or php-cgi), you’ll have to check your PATH actually contains the php5 executable.

  • are there open_basedir restrictions? The tcpdf library may use a folder (i.e., /tmp) outside of your document root.

  • what’s the memory_limit? Some hosts (especially shared hosting) cap it.


(Karsten Krohn) #17

This is my situation:

Shared Server (1and1):
Manual PDF report via mail() working fine.
Automatic PDF report via mail() not working.
No access to cron or bash, so the website-triggered process.
PHP 5.2.7 (using the .htaccess-trick, but does it care as long as I do not use the cron, right?)
Memory limit 40MB
No open_basedir restrictions
No entries in maillog :frowning:

For me, it looks like the process is not starting.
Can I check this somehow?


(bolero) #18

Karsten, I think if you set archiving to 3600 then you are using cron. Apart from that check the tmp directory in the piwik directory if it contains pdf reports. Also, compare the ticket link I provided and this one: 301 Moved Permanently for troubleshooting help.


(Karsten Krohn) #19

bolero,
I did not set up a cron job using cron.d (as described in How to Set up Auto-Archiving of Your Reports - Analytics Platform - Matomo)

I did set archiving to 3600, right. But that’s not cron, only a web-triggered sort of pseudo-cron, that is only actived as long as I have visitors on my website. Or did I missunderstood something?

Thanks for the link, I’ll check if it works for me and will report.


(bolero) #20

I see. I understand that you have a server of an unknown kind at 1and1 but also your own machine. I’d focus troubleshooting on your own one as you have more options. Nothing in the maillog? Grep for “noreply” in the maillog. If there’s nothing in the maillog and also no reports in the tmp dir then it’s likely the job wasn’t started or it failed because of an error (check your php_error.log). If you are sure it doesn’t run in a php error I would go to “cronned” execution as it’s natural to then assume that the “pseudo-cron” trigger doesn’t work somehow.