Authorisation of Google Analytics Importer fail: "Could not verify the security token on this form."

Hello,

I have been following this guide in order to setup the google analytics importer. Everything went smoothly until it came to actually authorising the importer. After clicking the “Authorise” button it takes me to the Google log in page as expected. However, after logging in and getting redirected back at https://matomo.my-domain.com I get the error “Could not verify the security token on this form.”

I tried searching up this issue and I found some suggestions that this issue could just be fixed by waiting and trying again. However, I have been re-trying this all throughout the day and it is consistently failing.

This may be unrelated, but I am also getting the error “The uploaded file couldn’t be processed. Please check if the file has a valid format.” when I try to upload a custom logo or favicon.

Any help would be appreciated.
Thanks,
~Paddy L.

I’ve had the same problem today. I got it working last week but now when I needed to reimport som stuff I got this error. I got the error when trying to “Re-authorize” and also after removing the authorization and authorizing again.

Hi , same Problem after upgrading to Version 4.1 of the plugin.
Can I downgrade the plugin to a previous Version until bug is fixed?

THX

Temporal solved.
On the Page:
(https://github.com/matomo-org/plugin-GoogleAnalyticsImporter/releases)
I have downloaded Version 4.02 of the plugin and installed it.

Now the Importer works!

This appears to be a session related issue w/ the current release. Unfortunately I can’t reproduce it myself. Can those affected check for the following:

  • at the end of the authorize workflow when you are redirected to matomo, is there a nonce= query parameter in the URL?
  • are you using any special configuration options / settings that might affect the way sessions are handled?
  • what hosting are you using?

In the meantime, downgrading is a workaround and should allow you to import successfully.

In my case I am self-hosting Matomo:

  • Matomo 4.1.1
  • Ubuntu 18.04 (LTS) x64
  • MySQL 5.7.33-0ubuntu0.18.04.1
  • PHP 8.0.1

There is no nonce= query parameter in the URL after being redirected back to Matomo. For me, this is a fresh install of Matomo so I am not using any special configuration options. The only configuration option I changed was to enable logging after experiencing this issue.

Hope this helps. Thanks,
~Paddy L.

Apologies, I mistyped, the query parameter should be state=. Can you check for that param? Are you hosting on your own hardware or using a hosting service? Can you think of any PHP settings that might cause issues with session storage?

And would you be able to provide the result of the System Check admin page (under the Diagnostic section)?

Hi, yes there is a state= parameter in the redirect URL. I am hosting using a DigitalOcean droplet. I’ve not changed any PHP settings except for the maximum post and upload size.

Here is the system check results:

# Mandatory checks

## PHP version >= 7.2.5: ✔ 8.0.1


## PDO extension: ✔ 


## PDO\MYSQL extension: ✔ 


## MYSQLI extension: ✔ 


## Other required extensions: ✔ zlib ✔ SPL ✔ iconv ✔ json ✔ mbstring ✔ Reflection


## Required functions: ✔ debug_backtrace ✔ eval ✔ hash ✔ gzcompress ✔ gzuncompress ✔ pack


## Required PHP configuration (php.ini): ✔ session.auto_start = 0 ✔ max_execution_time = 0 OR >= 30


## Directories with write access: ✔ $DOC_ROOT/tmp ✔ $DOC_ROOT/tmp/assets ✔ $DOC_ROOT/tmp/cache ✔ $DOC_ROOT/tmp/climulti ✔ $DOC_ROOT/tmp/latest ✔ $DOC_ROOT/tmp/logs ✔ $DOC_ROOT/tmp/sessions ✔ $DOC_ROOT/tmp/tcpdf ✔ $DOC_ROOT/tmp/templates_c



# Optional checks

## File integrity: ✔ 


## Tracker status: ✔ 


## Memory limit: ✔ 128M


## Time zone: ✔ 


## Open URL: ✔ fopen


## PageSpeed disabled: ✔ 


## GD > 2.x + Freetype (graphics): ✔ 


## Other extensions: ✔ json ✔ libxml ✔ dom ✔ SimpleXML


## Other functions: ✔ shell_exec ✔ set_time_limit ✔ mail ✔ parse_ini_file ✔ glob ✔ gzopen ✔ md5_file


## Filesystem: ✔ 


## Setup Cron (faster report loading): ⚠ Warning: For optimal performance and a speedy Matomo, it is highly recommended to set up a crontab to automatically archive your reports, and to disable browser triggering in the Matomo settings. <a href="https://matomo.org/docs/setup-auto-archiving/" target="_blank" rel="noreferrer noopener">Learn more.</a>


## Setup Cron - Managing processes via CLI: ✔ Ok


## Database abilities: ✔ UTF8mb4 charset ✔ LOAD DATA INFILE ✔ CREATE TEMPORARY TABLES ✔ Changing transaction isolation level


## Max Packet Size: ⚠ Warning: It is recommended to configure a 'max_allowed_packet' size in your MySQL database of at least 64MB. Configured is currently 16MB.


## Forced SSL Connection: ⚠ Warning: We recommend using Matomo over secure SSL connections only. To prevent insecure access over http, add <code>force_ssl = 1</code> to the <code>General</code> section in your Matomo config/config.ini.php file.


## Geolocation: ✔ 


## Update over HTTPS: ✔ 


## Writable JavaScript Tracker ("/matomo.js"): ✔ 



# Informational results

## Matomo Version: 4.1.1


## Matomo Update History: 4.1.1,


## Matomo Install Version: 4.1.1


## PHP_OS: Linux


## PHP SAPI: apache2handler


## Timezone Version: 0.system


## PHP Timezone: UTC


## PHP Time: 1612413227


## PHP Datetime: 2021-02-04 04:33:47


## PHP Disabled functions: pcntl_alarm, pcntl_fork, pcntl_waitpid, pcntl_wait, pcntl_wifexited, pcntl_wifstopped, pcntl_wifsignaled, pcntl_wifcontinued, pcntl_wexitstatus, pcntl_wtermsig, pcntl_wstopsig, pcntl_signal, pcntl_signal_get_handler, pcntl_signal_dispatch, pcntl_get_last_error, pcntl_strerror, pcntl_sigprocmask, pcntl_sigwaitinfo, pcntl_sigtimedwait, pcntl_exec, pcntl_getpriority, pcntl_setpriority, pcntl_async_signals, pcntl_unshare, 


## PHP INI max_execution_time: 30


## PHP INI post_max_size: 64M


## PHP INI max_input_vars: 1000


## PHP INI zlib.output_compression: 


## Suhosin Installed: 0


## DB Prefix: matomo_


## DB Charset: utf8mb4


## DB Adapter: PDO\MYSQL


## MySQL Version: 5.7.33-0ubuntu0.18.04.1


## Num Tables: 38


## Browser Segment Archiving Enabled: 1


## Development Mode Enabled: 0


## Internet Enabled: 1


## Multi Server Environment: 0


## Custom User Path: 0


## Custom Include Path: 0


## Plugins Activated: API, Actions, Annotations, BotTracker 2.00, BulkTracking, Contents, CoreAdminHome, CoreConsole, CoreHome, CorePluginsAdmin, CoreUpdater, CoreVisualizations, CustomDimensions, CustomJsTracker, Dashboard, DevicePlugins, DevicesDetection, Diagnostics, Ecommerce, Events, Feedback, GeoIp2, Goals, Heartbeat, ImageGraph, Insights, Installation, Intl, IntranetMeasurable, LanguagesManager, Live, LogViewer 4.0.1, Login, Marketplace, MobileMessaging, Modern 1.0.4, Monolog, Morpheus, MultiSites, Overlay, PagePerformance, PrivacyManager, ProfessionalServices, Proxy, Referrers, Resolution, RssWidget, SEO, ScheduledReports, SegmentEditor, SitesManager, Tour, Transitions, TwoFactorAuth, UserCountry, UserCountryMap, UserId, UserLanguage, UsersManager, VisitFrequency, VisitTime, VisitorInterest, VisitsSummary, WebsiteMeasurable, Widgetize


## Plugins Deactivated: CustomVariables, DBStats, MobileAppMeasurable, Provider, TagManager


## Plugins Invalid: 


## Server Info: Apache/2.4.29 (Ubuntu)


## Had visits in last 1 day: 1


## Had visits in last 3 days: 1


## Had visits in last 5 days: 1


## Archive Time Last Started: 0


## Archive Time Last Finished: 0


## Num invalidations: 6 queued, 0 in progress


## User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/88.0.4324.96 Safari/537.36


## Browser Language: en-us,en


## Anonymize Referrer: 


## Do Not Track enabled: 1

Edit: I can also confirm that downgrading to version 4.0.4 of the importer fixes this issue, suggesting that it was introduced in the 4.1.0 release.

We run our WordPress websites on identical servers and have never before had an issue with the Importer Plugin. Today, I encountered this issue with version 4.1.0. I tried all sorts of things like disabling plugins, using different browsers, disabling any form of caching in WP, but nothing worked. I then downgraded to version 4.0.4 and it started working again with no issues.

The end url did have a state token and looked like this:
https://ourwebsite.com/wp-content/plugins/matomo/app/index.php?module=GoogleAnalyticsImporter&action=processAuthCode&state=xxxxx24cba7xxxxxxxxxx9lce284xxxxx&code=4/0xx0e-g7xxqLjDxcxxxxxxxxxxxxxJWPd-lQnxxxxxxxxxxcj3HN_qqZobg2xxxxxxxxxxx&scope=https://www.googleapis.com/auth/analytics.readonly

This is the system report from WordPress (after i reverted to 4.0.4):

				  # Matomo

* Matomo Plugin Version: 4.1.3
* Config exists and is writable.: Yes ("$ABSPATH/wp-content/uploads/matomo/config/config.ini.php" )
* JS Tracker exists and is writable.: Yes ("$ABSPATH/wp-content/uploads/matomo/matomo.js" )
* Plugin directories: Yes ([{"pluginsPathAbsolute":"$ABSPATH\/wp-content\/plugins\/matomo\/plugins","webrootDirRelativeToMatomo":"..\/"},{"pluginsPathAbsolute":"$ABSPATH\/wp-content\/plugins","webrootDirRelativeToMatomo":"..\/..\/"}])
* Tmp directory writable: Yes ($ABSPATH/wp-content/cache/matomo)
* Matomo Version: 4.1.1
* Matomo Blog idSite: 1
* Matomo Install Version: 4.1.3 (Install date: 2021-02-03 17:12:07)
* Upgrades outstanding: No
* Upgrade in progress: No

## Endpoints

* Matomo JavaScript Tracker URL:  ($site_url/wp-content/uploads/matomo/matomo.js)
* Matomo JavaScript Tracker - WP Rest API:  ($site_url/wp-json/matomo/v1/hit/)
* Matomo HTTP Tracking API:  ($site_url/wp-content/plugins/matomo/app/matomo.php)
* Matomo HTTP Tracking API - WP Rest API:  ($site_url/wp-json/matomo/v1/hit/)

## Crons

* Server time: 2021-02-10 14:34:33
* Blog time: 2021-02-10 16:34:33 (Below dates are shown in blog timezone)
* Sync users & sites: Next run: 2021-02-10 17:12:06 (37 min 33s) ( Last started: 2021-02-09 17:14:43 (-23 hours 19 min). Last ended: 2021-02-09 17:14:44 (-23 hours 19 min). Interval: daily)
* Archive: Next run: 2021-02-10 17:12:06 (37 min 33s) ( Last started: 2021-02-10 16:12:13 (-22 min 20s). Last ended: 2021-02-10 16:12:13 (-22 min 20s). Interval: hourly)
* Update GeoIP DB: Next run: 2021-03-05 17:12:06 (23 days 0 hours) ( Last started: 2021-02-03 17:13:11 (-6 days 23 hours). Last ended: 2021-02-03 17:13:14 (-6 days 23 hours). Interval: matomo_monthly)

## Mandatory checks

* PHP version >= : ok 
* PDO extension: ok 
* PDO\MYSQL extension: ok 
* MYSQLI extension: ok 
* Other required extensions: ok 
* Required functions: ok 
* Required PHP configuration (php.ini): ok 
* Directories with write access: ok 
* Directories with write access for Tag Manager: ok 

## Optional checks

* Tracker status: ok 
* Memory limit: ok 
* Time zone: ok 
* Open URL: ok 
* PageSpeed disabled: ok 
* GD > 2.x + Freetype (graphics): ok 
* Other extensions: ok 
* Other functions: ok 
* Filesystem: ok 
* Last Successful Archiving Completion: ok 
* Database abilities: ok 
* Max Packet Size: ok 
* Geolocation: ok 
* Update over HTTPS: ok 
* Writable JavaScript Tracker ("/matomo.js"): ok 
* [GoogleAnalyticsImporter] Required PHP Functions: ok 
* [GoogleAnalyticsImporter] Required Executables (php): ok 
* [GoogleAnalyticsImporter] Required Executables (nohup): ok 
* Supports Async Archiving: Yes
* Location provider ID: geoip2php
* Location provider available: Yes
* Location provider working: Yes
* Had visit in last 5 days: Yes

## Matomo Settings

* Track mode: default
* Track codeposition: footer
* Track api endpoint: default
* Track js endpoint: default
* Version history: 4.1.3
* Core version: 4.1.1
* Last tracking settings update: 1612365380
* Last settings update: 1612398527
* Track ecommerce: No
* Track search: Yes
* Track 404: Yes
* Disable cookies: Yes
* Show get started page: 0

## Logs

* archive_boot: 2021-02-10 16:12:10 (Matomo error: 8192: Function create_function() is deprecated in $ABSPATH/wp-content/plugins/our-team-by-woothemes/classes/class-woothemes-widget-our-team.php:324 => bootstrap.php:56; bootstrap.php:85; class-woothemes-widget-our-team.php:324; woothemes-our-team.php:20; wp-settings.php:388; wp-config.php:78; wp-load.php:37; bootstrap.php:95; console:11;)
* archive_boot: 2021-02-10 16:12:11 (Matomo error: 8192: Function create_function() is deprecated in $ABSPATH/wp-content/plugins/our-team-by-woothemes/classes/class-woothemes-widget-our-team.php:324 => bootstrap.php:56; bootstrap.php:85; class-woothemes-widget-our-team.php:324; woothemes-our-team.php:20; wp-settings.php:388; wp-config.php:78; wp-load.php:37; bootstrap.php:95; console:11;)
* archive_boot: 2021-02-10 16:13:03 (Matomo error: 8192: Function create_function() is deprecated in $ABSPATH/wp-content/plugins/our-team-by-woothemes/classes/class-woothemes-widget-our-team.php:324 => bootstrap.php:56; bootstrap.php:85; class-woothemes-widget-our-team.php:324; woothemes-our-team.php:20; wp-settings.php:388; wp-config.php:78; wp-load.php:37; bootstrap.php:95; console:11;)
* archive_boot: 2021-02-10 16:13:04 (Matomo error: 8192: Function create_function() is deprecated in $ABSPATH/wp-content/plugins/our-team-by-woothemes/classes/class-woothemes-widget-our-team.php:324 => bootstrap.php:56; bootstrap.php:85; class-woothemes-widget-our-team.php:324; woothemes-our-team.php:20; wp-settings.php:388; wp-config.php:78; wp-load.php:37; bootstrap.php:95; console:11;)
* archive_boot: 2021-02-10 16:13:05 (Matomo error: 8192: Function create_function() is deprecated in $ABSPATH/wp-content/plugins/our-team-by-woothemes/classes/class-woothemes-widget-our-team.php:324 => bootstrap.php:56; bootstrap.php:85; class-woothemes-widget-our-team.php:324; woothemes-our-team.php:20; wp-settings.php:388; wp-config.php:78; wp-load.php:37; bootstrap.php:95; console:11;)
* archive_boot: 2021-02-10 16:13:06 (Matomo error: 8192: Function create_function() is deprecated in $ABSPATH/wp-content/plugins/our-team-by-woothemes/classes/class-woothemes-widget-our-team.php:324 => bootstrap.php:56; bootstrap.php:85; class-woothemes-widget-our-team.php:324; woothemes-our-team.php:20; wp-settings.php:388; wp-config.php:78; wp-load.php:37; bootstrap.php:95; console:11;)

# WordPress

* Home URL: $site_url
* Site URL: $site_url
* WordPress Version: 5.6.1
* Number of blogs: 1
* Multisite Enabled: No
* Network Enabled: No
* WP_DEBUG: No
* WP_DEBUG_DISPLAY: Yes
* WP_DEBUG_LOG: No
* DISABLE_WP_CRON: -
* FORCE_SSL_ADMIN: Yes
* WP_CACHE: Yes
* CONCATENATE_SCRIPTS: -
* COMPRESS_SCRIPTS: -
* COMPRESS_CSS: -
* ENFORCE_GZIP: -
* WP_LOCAL_DEV: -
* DIEONDBERROR: -
* WPLANG: -
* ALTERNATE_WP_CRON: -
* WP_CRON_LOCK_TIMEOUT: 60
* WP_DISABLE_FATAL_ERROR_HANDLER: -
* MATOMO_SUPPORT_ASYNC_ARCHIVING: -
* MATOMO_TRIGGER_BROWSER_ARCHIVING: -
* MATOMO_ENABLE_TAG_MANAGER: -
* MATOMO_SUPPRESS_DB_ERRORS: -
* MATOMO_ENABLE_AUTO_UPGRADE: -
* MATOMO_DEBUG: -
* MATOMO_SAFE_MODE: -
* MATOMO_GLOBAL_UPLOAD_DIR: -
* MATOMO_LOGIN_REDIRECT: -
* Permalink Structure: /%postname%/
* Possibly uses symlink: No
* Compatible content directory: Yes

# WordPress Plugins


## MU Plugins

* ManageWP - Worker Loader: 

## Plugins

* Disable Comments: 2.1.0
* Google Analytics Importer (Matomo Plugin): 4.0.4
* ManageWP - Worker: 4.9.7 (Network enabled)
* Matomo Analytics - Ethical Stats. Powerful Insights.: 4.1.3
* Our Team: 1.4.1
* Slider Revolution: 6.3.9
* Testimonials: 1.5.4
* WooSlider: 2.3.0
* WP Rocket: 3.8.4
* Yoast SEO: 15.8
* Active Plugins: 8 (worker GoogleAnalyticsImporter disable-comments matomo our-team-by-woothemes revslider wordpress-seo wp-rocket)
* Theme: Divi (Divi)

# Server

* Server Info: Apache
* PHP OS: Linux
* PHP Version: 7.4.15
* PHP SAPI: litespeed
* PHP Found Binary: php -q
* Timezone: UTC
* WP timezone: +02:00
* Locale: en_GB
* User Locale: en_US
* Memory Limit: 2048M (At least 128MB recommended. Depending on your traffic 256MB or more may be needed.)
* WP Memory Limit: 40M
* WP Max Memory Limit: 2048M
* Timezone version: 0.system
* Time: 1612967673
* Max Execution Time: 300
* Max Post Size: 256M
* Max Upload Size: 268435456
* Max Input Vars: 5000
* Disabled PHP functions: No
* zlib.output_compression is off: Yes
* Curl Version: 7.29.0, NSS/3.53.1
* Suhosin installed: No

# Database

* MySQL Version: 5.7.32
* Mysqli Connect: Yes
* Force MySQL over Mysqli: No
* DB Prefix: wp_
* DB CHARSET: utf8mb4
* DB COLLATE: 
* SHOW ERRORS: No
* SUPPRESS ERRORS: No
* Uses Socket: No
* Uses IPv6: No
* Matomo tables found: 58
* Matomo users found: 7
* Matomo sites found: 1
* Required permissions: OK

# Browser

* Browser:  (Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/87.0.4280.88 Safari/537.36)
* Language: en-us,en

Redirected back to Matomo with: https://mato.self-hosted.com/index.php?module=GoogleAnalyticsImporter&action=processAuthCode&state=e7eredacted2af&code=4/0AY0e-g7Kredactedrg&scope=https://www.googleapis.com/auth/analytics.readonly

No nonce. Nothing special, was working now broke. Also search console plugin also now broken. On prem hosting.

That &code=4/0... looks like it could be problematic. The / doesn’t look to be url encoded.

I’m seeing this too. I get the parameters module, action, state, code, and scope in the redirect URL, all with seemingly sensible values. I run this on a pretty standard Ubuntu droplet on DigitalOcean and haven’t really changed anything or done any special settings for PHP etc. This is my Matomo diagnostic:

# Mandatory checks

## PHP version >= 7.2.5: ✔ 7.4.3


## PDO extension: ✔ 


## PDO\MYSQL extension: ✔ 


## MYSQLI extension: ✔ 


## Other required extensions: ✔ zlib ✔ SPL ✔ iconv ✔ json ✔ mbstring ✔ Reflection


## Required functions: ✔ debug_backtrace ✔ eval ✔ hash ✔ gzcompress ✔ gzuncompress ✔ pack


## Required PHP configuration (php.ini): ✔ session.auto_start = 0 ✔ max_execution_time = 0 OR >= 30


## Directories with write access: ✔ $DOC_ROOT/tmp ✔ $DOC_ROOT/tmp/assets ✔ $DOC_ROOT/tmp/cache ✔ $DOC_ROOT/tmp/climulti ✔ $DOC_ROOT/tmp/latest ✔ $DOC_ROOT/tmp/logs ✔ $DOC_ROOT/tmp/sessions ✔ $DOC_ROOT/tmp/tcpdf ✔ $DOC_ROOT/tmp/templates_c



# Optional checks

## File integrity: ✔ 


## Tracker status: ✔ 


## Memory limit: ✔ 128M


## Time zone: ✔ 


## Open URL: ✔ fopen


## PageSpeed disabled: ✔ 


## GD > 2.x + Freetype (graphics): ✔ 


## Other extensions: ✔ json ✔ libxml ✔ dom ✔ SimpleXML


## Other functions: ✔ shell_exec ✔ set_time_limit ✔ mail ✔ parse_ini_file ✔ glob ✔ gzopen ✔ md5_file


## Filesystem: ✔ 


## Setup Cron - Managing processes via CLI: ✔ Ok


## Last Successful Archiving Completion: ✔ The archiving process completed successfully 00:04:57 ago.


## Database abilities: ✔ UTF8mb4 charset ✔ LOAD DATA INFILE ✔ CREATE TEMPORARY TABLES ✔ Changing transaction isolation level


## Max Packet Size: ✔ 


## Forced SSL Connection: ✔ 


## Geolocation: ✔ 


## Update over HTTPS: ✔ 


## Writable JavaScript Tracker ("/matomo.js"): ✔ 


## [GoogleAnalyticsImporter] Required PHP Functions: ✔ 


## [GoogleAnalyticsImporter] Required Executables (php): ✔ 


## [GoogleAnalyticsImporter] Required Executables (nohup): ✔ 



# Informational results

## Matomo Version: 4.1.1


## Matomo Update History: 4.1.1,


## Matomo Install Version: 4.1.1


## PHP_OS: Linux


## PHP_BINARY: /usr/sbin/php-fpm7.4


## PHP SAPI: fpm-fcgi


## Timezone Version: 0.system


## PHP Timezone: UTC


## PHP Time: 1613507098


## PHP Datetime: 2021-02-16 20:24:58


## PHP Disabled functions: pcntl_alarm, pcntl_fork, pcntl_waitpid, pcntl_wait, pcntl_wifexited, pcntl_wifstopped, pcntl_wifsignaled, pcntl_wifcontinued, pcntl_wexitstatus, pcntl_wtermsig, pcntl_wstopsig, pcntl_signal, pcntl_signal_get_handler, pcntl_signal_dispatch, pcntl_get_last_error, pcntl_strerror, pcntl_sigprocmask, pcntl_sigwaitinfo, pcntl_sigtimedwait, pcntl_exec, pcntl_getpriority, pcntl_setpriority, pcntl_async_signals, pcntl_unshare, 


## PHP INI max_execution_time: 30


## PHP INI post_max_size: 8M


## PHP INI max_input_vars: 1000


## PHP INI zlib.output_compression: 


## Suhosin Installed: 0


## DB Prefix: matomo_


## DB Charset: utf8mb4


## DB Adapter: PDO\MYSQL


## MySQL Version: 10.3.25-MariaDB-0ubuntu0.20.04.1


## Num Tables: 206


## Browser Segment Archiving Enabled: 1


## Development Mode Enabled: 0


## Internet Enabled: 1


## Multi Server Environment: 0


## Custom User Path: 0


## Custom Include Path: 0


## Plugins Activated: API, Actions, Annotations, BulkTracking, Contents, CoreAdminHome, CoreConsole, CoreHome, CorePluginsAdmin, CoreUpdater, CoreVisualizations, CustomDimensions, CustomJsTracker, Dashboard, DevicePlugins, DevicesDetection, Diagnostics, Ecommerce, Events, Feedback, GeoIp2, Goals, GoogleAnalyticsImporter 4.1.0, Heartbeat, ImageGraph, Insights, Installation, Intl, IntranetMeasurable, LanguagesManager, Live, Login, Marketplace, MobileMessaging, Monolog, Morpheus, MultiSites, Overlay, PagePerformance, PrivacyManager, ProfessionalServices, Proxy, Referrers, Resolution, RssWidget, SEO, ScheduledReports, SegmentEditor, SitesManager, TasksTimetable 4.0.2, Tour, Transitions, TwoFactorAuth, UserCountry, UserCountryMap, UserId, UserLanguage, UsersManager, VisitFrequency, VisitTime, VisitorInterest, VisitsSummary, WebsiteMeasurable, Widgetize


## Plugins Deactivated: CustomVariables, DBStats, MobileAppMeasurable, Provider, TagManager


## Plugins Invalid: 


## Server Info: nginx/1.18.0


## Had visits in last 1 day: 1


## Had visits in last 3 days: 1


## Had visits in last 5 days: 1


## Archive Time Last Started: 1613506801


## Archive Time Last Finished: 1613506801


## Num invalidations: 0 queued, 0 in progress


## User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:85.0) Gecko/20100101 Firefox/85.0


## Browser Language: en-us,en


## Anonymize Referrer: 


## Do Not Track enabled: 1



Hi,

This issue should be fixed with

and this change in Matomo:

Could someone maybe try out applying the changes manually to see if it fixes it and then report back to @diosmosis.

Still getting this error with version 4.2.0

Did you also update the Google Analytics plugin to 4.1.1?

yes I did, or I should say the automatic update said it did