"Array to string conversion" problem in Piwik 2.8.3


#1

Hello,

since update to 2.8.3 the ecommerce visitor protocol on the ecommerce page do not show the visitors data anymore.

Instead, there is a notice:

Notice:Array to string conversion in /home/sites/mydomain.net/subdomains/shop/piwik/tmp/templates_c/ba/ce/7fde9185ff42055539941c3b583631e73a0b08821a97c3db94721f791a80.php on line 87

Backtrace -->

#0 Piwik\Error::errorHandler(…) called at [/home/sites/mydomain.net/subdomains/shop/piwik/tmp/templates_c/ba/ce/7fde9185ff42055539941c3b583631e73a0b08821a97c3db94721f791a80.php:87]
#1 __TwigTemplate_bace7fde9185ff42055539941c3b583631e73a0b08821a97c3db94721f791a80->doDisplay(…) called at [/home/sites/mydomain.net/subdomains/shop/piwik/vendor/twig/twig/lib/Twig/Template.php:279]
#2 Twig_Template->displayWithErrorHandling(…) called at [/home/sites/mydomain.net/subdomains/shop/piwik/vendor/twig/twig/lib/Twig/Template.php:253]
#3 Twig_Template->display(…) called at [/home/sites/mydomain.net/subdomains/shop/piwik/tmp/templates_c/ec/fd/542b102c9bbb13da12311596f06049e870929c22c283b03a44bcc1254f8a.php:138]
#4 __TwigTemplate_ecfd542b102c9bbb13da12311596f06049e870929c22c283b03a44bcc1254f8a->doDisplay(…) called at [/home/sites/mydomain.net/subdomains/shop/piwik/vendor/twig/twig/lib/Twig/Template.php:279]
#5 Twig_Template->displayWithErrorHandling(…) called at [/home/sites/mydomain.net/subdomains/shop/piwik/vendor/twig/twig/lib/Twig/Template.php:253]
#6 Twig_Template->display(…) called at [/home/sites/mydomain.net/subdomains/shop/piwik/tmp/templates_c/be/da/1f9d769de757e098c3062bc888b74e8fff574bdec01bf9f7febf2783fa5a.php:115]
#7 __TwigTemplate_beda1f9d769de757e098c3062bc888b74e8fff574bdec01bf9f7febf2783fa5a->doDisplay(…) called at [/home/sites/mydomain.net/subdomains/shop/piwik/vendor/twig/twig/lib/Twig/Template.php:279]
#8 Twig_Template->displayWithErrorHandling(…) called at [/home/sites/mydomain.net/subdomains/shop/piwik/vendor/twig/twig/lib/Twig/Template.php:253]
#9 Twig_Template->display(…) called at [/home/sites/mydomain.net/subdomains/shop/piwik/vendor/twig/twig/lib/Twig/Template.php:264]
#10 Twig_Template->render(…) called at [/home/sites/mydomain.net/subdomains/shop/piwik/vendor/twig/twig/lib/Twig/Environment.php:292]
#11 Twig_Environment->render(…) called at [/home/sites/mydomain.net/subdomains/shop/piwik/core/View.php:259]
#12 Piwik\View->renderTwigTemplate(…) called at [/home/sites/mydomain.net/subdomains/shop/piwik/core/View.php:253]
#13 Piwik\View->render(…) called at [/home/sites/mydomain.net/subdomains/shop/piwik/core/Plugin/ViewDataTable.php:415]
#14 Piwik\Plugin\ViewDataTable->render(…) called at [/home/sites/mydomain.net/subdomains/shop/piwik/core/Plugin/Report.php:304]
#15 Piwik\Plugin\Report->render(…) called at [/home/sites/mydomain.net/subdomains/shop/piwik/core/Plugin/Controller.php:327]
#16 Piwik\Plugin\Controller->renderReport(…) called at [/home/sites/mydomain.net/subdomains/shop/piwik/plugins/Live/Controller.php:70]
#17 Piwik\Plugins\Live\Controller->getVisitorLog(…) called at [:]
#18 call_user_func_array(…) called at [/home/sites/mydomain.net/subdomains/shop/piwik/core/FrontController.php:587]
#19 Piwik\FrontController->doDispatch(…) called at [/home/sites/mydomain.net/subdomains/shop/piwik/core/FrontController.php:95]
#20 Piwik\FrontController->dispatch(…) called at [/home/sites/mydomain.net/subdomains/shop/piwik/plugins/Goals/Controller.php:109]
#21 Piwik\Plugins\Goals\Controller->getEcommerceLog(…) called at [:]
#22 call_user_func_array(…) called at [/home/sites/mydomain.net/subdomains/shop/piwik/core/FrontController.php:587]
#23 Piwik\FrontController->doDispatch(…) called at [/home/sites/mydomain.net/subdomains/shop/piwik/core/FrontController.php:95]
#24 Piwik\FrontController->dispatch(…) called at [/home/sites/mydomain.net/subdomains/shop/piwik/core/dispatch.php:34]
#25 require_once(…) called at [/home/sites/mydomain.net/subdomains/shop/piwik/index.php:46]

What to do now?

Best regards, fibergirl

Additional info:
This happens only if ecommerce count = 0.
For example on Monday morning, if statistics are displayed weekly.
As soon there is the first ecommerce transactions count != 0, the ecommerce visitors protocol starts appearing normal.


(Matthieu Aubry) #2

can you please create an issue on tracker: Issues · matomo-org/piwik · GitHub
and paste a screenshot showing the error rather than the full error message?

Thanks!


#3

Same here. I assume there’s no github ticket yet?


(Matthieu Aubry) #4

first try with latest beta: I would like to test early beta and RC releases, how do I enable automatic updates to use these development versions? - Analytics Platform - Matomo

if you still have the problem then please create an issue with screenshot - thanks