Archiving stopped working afte update (1.1.1 -> 1.7)


(Fellmer Lloyd) #1

Hi all

We’ve finally managed to upgrade our piwik installation from 1.1.1 to 1.7.
However, we don’t see any data since that time (2 days ago).

I’ve checked the table “piwik_log_visit”.
It contains a lot of records from today and yesterday.

Next I checked the new archiving script (archive.php).
I had to fix an SLL error first.

The script rejected our SSL cert (-.-).
This (rather bad) hack fixed the error:
curl_setopt ($ch, CURLOPT_SSL_VERIFYHOST, 0);
curl_setopt ($ch, CURLOPT_SSL_VERIFYPEER, 0);

Now the script seems to be able to run.
However, the following error appears a lot of times (I guess once per site):

[2012-02-16 09:08:52] [bbefb723] WARNING: Empty or invalid response for website
id 11, Time elapsed: 13.847s, skipping

[2012-02-16 09:08:58] [bbefb723] ERROR: Got invalid response from API request: h
ttp://server/piwik/index.php?module=API&method=VisitsSummary.getVisits&idS
ite=12&period=day&date=last52&format=php&token_auth=xxx&trigger=archivephp. Response was ’ IIS 7.0 Detailed Error - 502.2

  • Bad Gateway ’

[2012-02-16 09:09:15] [bbefb723] WARNING: Empty or invalid response for website
id 13, Time elapsed: 17.334s, skipping

Any clues?

Regards,
Fellmer


(Matthieu Aubry) #2

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML
1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd"> <html xmln
s="http://www.w3.org/1999/xhtml"> <head> <title>IIS 7.0 Detailed Error - 502.2

check your IIS error logs, something is not working or crashing (update php, etc.?)


#3

Hi matt,

I’ve the same problem, that curl doesn’t accept my valid SSL-certificate. Is there an option not to use SSL?

Another disadvantage with the archive.php: It’s not possible to set a nice level as it calls URLs and spawns apache-processes for archiving. Is it still possible to use the existing “archive.sh” script?

The rest works fine! You did a great job (as always)!

Thanks in advance
tobe


(Fellmer Lloyd) #4

Hmm… I’ve checked the Application Log. It’s full of errors like this one (not just during archiving):
Faulting application php.exe, version 5.3.2.0, time stamp 0x4b8ecc03, faulting module php_pdo_mysql.dll, version 5.3.2.0, time stamp 0x4b8ecaa8, exception code 0xc0000005, fault offset 0x0000196d, process id 0x1038, application start time 0x01ccecb07e51f5b1.

I guess something is broken… can I get some more detailed information?
I must admit that I’m not an PHP expert (but I now IIS pretty good).

Regards


(Matthieu Aubry) #5

I must admit that I’m not an PHP expert (but I now IIS pretty good).

The bug you have is a PHP bug, so update your php if not to the latest verison already.

Another disadvantage with the archive.php: It’s not possible to set a nice level as it calls URLs and spawns apache-processes for archiving. Is it still possible to use the existing “archive.sh” script?

Yes of course, the old script will always work fine.

I’ve the same problem, that curl doesn’t accept my valid SSL-certificate. Is there an option not to use SSL?

Canyou please create a bug report in dev.piwik.org ? we would want to fix that!!


(Fellmer Lloyd) #6

Hi all

Thanks for the hint - updating the PHP Version to 5.3.10 solved the archiving Problem.
The instability/differences between such minor versions always confuses me…

I’ve created a ticket regarding the SSL error:

Regards,
Fellmer


#7

Checked permissions and they were fine the Cron was failing each time running, I cleared the temp files i found in there. We’ll see if that helps? Cron completes without errors. Is their a way to manually fire the reports off? Otherwise guess I’ll have to wait until tomorrow morning to see if my inbox is full of reports? I also updated from PHP 5.3 top 5.4.