Archiving process Error - PHP problem

Hello,
We have just installed the Matomo plugin in our WebSite. Everything is OK, except the archiving process.
When we manually try to archive reports by clicking on the button (Diagnostics / Trouble Shouting menu), we get the following error message :

‘Got invalid response from API request: ?module=API&method=CoreAdminHome.archiveReports&idSite=1&period=day&date=2023-01-09&format=json&trigger=archivephp. The response was empty. This usually means a server error. A solution to this error is generally to increase the value of ‘memory_limit’ in your php.ini file. For more information and the error message please check in your PHP CLI error log file. As this core:archive command triggers PHP processes over the CLI, you can find where PHP CLI logs are stored by running this command: php -i | grep error_log’
‘Error unserializing the following response from ?module=API&method=CoreAdminHome.archiveReports&idSite=1&period=day&date=2023-01-09&format=json&trigger=archivephp: ‘’’
*

In the php.ini file I have the setting :
memory_limit = 1024M
which is “normally” enough, that’s why we don’t understand this error message.

Thanks a lot for your help,
Best Regards,
Jérôme

Hi @Mutuelle403 thanks for reaching out. Can you please provide us a copy of your system check for review: How do I find and copy the system report in Matomo for WordPress?

Hello,
Thanks a lot for your reply.
Here the requested report.
Thanks a lot for your help and support,
Best Regards,
Jérôme

Beginning :

WordPress Plugins

MU Plugins

  • ManageWP - Worker Loader: 1.0.0

Plugins

  • Bandeau cookies: 0.1
  • Better Search Replace: 1.4 (Network enabled)
  • Classic Editor: 1.6.2
  • Contact Form 7: 5.4.1
  • Cookiebot CMP by Usercentrics | The reliable, flexible and easy to use consent solution: 4.2.3
  • Font Awesome: 4.3.1
  • ManageWP - Worker: 4.9.16 (Network enabled)
  • Matomo Analytics - Ethical Stats. Powerful Insights.: 4.13.0
  • PHP Compatibility Checker: 1.5.2
  • Popup Builder: 4.0.4
  • Redirection: 5.1.3
  • Simpliest Social Share: 1.1
  • Soil: 3.7.2
  • UpdraftPlus - Backup/Restore: 1.16.63
  • Wordfence Security: 7.5.6 (Network enabled)
  • WordPress Importer: 0.7
  • WPBakery Page Builder: 6.7.0
  • WP Media folders: 1.1.10
  • WP Super Cache: 1.7.4
  • Yoast SEO: 17.4
  • Active Plugins: 17 (worker better-search-replace classic-editor contact-form-7 cookiebot cvw-social-share font-awesome js_composer matomo php-compatibility-checker popup-builder redirection soil updraftplus wordpress-importer wordpress-seo wp-media-folders)
  • Theme: mutuelle403 (mutuelle403)

Server

  • Server Info: Apache
  • Apache AddHandler support: Supported
  • PHP OS: Linux
  • PHP Version: 7.3.31
  • PHP SAPI: fpm-fcgi
  • PHP Binary Name: php-fpm
  • PHP Maxmind DB extension: Not loaded
  • PHP Error Reporting: 0 After bootstrap: 0
  • PHP Found Binary: php -q
  • Timezone: UTC
  • WP timezone: Europe/Paris
  • Locale: fr_FR
  • User Locale: fr_FR
  • Memory Limit: 192M (At least 128MB recommended. Depending on your traffic 256MB or more may be needed.)
  • WP Memory Limit: 128M
  • WP Max Memory Limit: 128M
  • Timezone version: 2020.4
  • Time: 1673940532
  • Max Execution Time: 180
  • Max Post Size: 128M
  • Max Upload Size: 134217728
  • Max Input Vars: 2500
  • Disabled PHP functions: No
  • zlib.output_compression is off: Yes
  • Curl Version: 7.52.1, OpenSSL/1.0.2u
  • Suhosin installed: No

End :
PHP cli

  • PHP cli Version: 7.3.31
  • MySQLi support: ok

Database

  • MySQL Version: 8.0.18
  • Mysqli Connect: Yes
  • Force MySQL over Mysqli: No
  • DB Prefix: m403_
  • DB CHARSET: utf8
  • DB COLLATE:
  • SHOW ERRORS: No
  • SUPPRESS ERRORS: No
  • Uses Socket: No
  • Uses IPv6: No
  • Matomo tables found: 81
  • DB tables exist: Yes
  • Matomo users found: 4
  • Matomo sites found: 1
  • Permissions obligatoires: OK

Browser

  • Browser: (Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/108.0.0.0 Safari/537.36)
  • Language: fr,en-us,en

Hi @Mutuelle403 this may be related to the memory limit on your server not applying

  • Memory Limit: 192M (At least 128MB recommended. Depending on your traffic 256MB or more may be needed.)

Are you able to ensure this is applied as 256MB or more ?

Hello,
Thanks a lot for your reply. Unfortunately I cannot change this parameter because the Web site is hosted on a shared environment.
Nevertheless, we only have around 200 connections per day, so I don’t think that the memory limit is the bottleneck.
Looking on Internet, I have seen that this error message, most of the time, has nothing to do with the memory limit :-(.
Do you have nay other ideas ?
Thanks a lot fro your help and support,
Best Regards,
Jérôme

Hi @Mutuelle403 You can disable the archiving asynchronous mode (by adding in his wp-config.php file the following content;

if (!defined(‘MATOMO_SUPPORT_ASYNC_ARCHIVING’)){define(‘MATOMO_SUPPORT_ASYNC_ARCHIVING’, false);}

it solves 90% or the archiving problem.
But if you want to get the origin of the problem, you will need to create a feature request on our issue tracker here:
https://github.com/matomo-org/matomo/issues

This is so we have it noted down for the team to look into when possible.

We’re looking forward to hearing from you or seeing your report on Github,

Hi Varun,

Fantastic !! adding this line in wp-config.php has solved the problem.
Now, data are correctly archived.
Thanks a lot for you help and support, I give you 5 stars ! :slight_smile:

Best Regards,
Jérôme