Archiving of your reports hasn't been executed recently


I am trying to work on the funnels (setup in June) and make some changes (august), and after the changes, I run force-archiving and it works and shows data.

But currently, I have made changes (sept), I tried archiving and it still shows no data for the June-July-august months and only shows data for Sept.

It does show conversions under the goal itself was converted but shows no other data

refer screenshot

I checked the visit log segments but it says no data. Is my data lost? or Are there issues with archiving?

Please guide for solution


Is your cron-job still running successfully (have you checked its output log for errors?)?
And if you don’t have a cron-job set up, have you enabled browser archiving?

Hi Lucas,

Thanks a lot for helping
I asked our database admin to run this command -/var/www/html/console core:archive --force-idsites=4

and it was completed successfully on his end, but when I login back to matomo and opened the funnel it still shows

and no data for June-July-aug-months, it only shows data in September

It shows data under “the goal; itself was converted” - Can we recover this data back to show in funnels ?

How can I tell our super admin to check if they have a cron-job setup and if they have browser archiving enabled?

and also please guide about the invalidate historical reports process -

Is this related to archiving process?

please guide for queries?

Hi there,

You would want to invalidate reports as far back as you require. This should then process all the data for that period. Archiving could be failing for a few reasons like lack of memory. Please check our guide here: