Archiving failing in high traffic site + custom reports + custom dimensions


#1

Hi,

We are seeing this error in the log when our archiving process reaches a very high traffic Web site.

Error: Got invalid response from API request: ?module=API&method=API.get&idSite=1228&period=week&date=last12&format=php&trigger=archivephp. The response was empty. This usually means a server error. A solution to this error is generally to increase the value of ‘memory_limit’ in your php.ini file.

This only started happening when we started using the custom reports plugin.

We are not seeing any errors in the log and I’m wondering which php.ini file would control error reporting and logging for the command-line arching process.

The error message says to increase memory_limit, but that’s always -1 for php cli. I’m not sure if this cli app is actually calling the API via CURL or what. We don’t see errors added to the apache error_log either.

Any advice on how to debug further?


#2

I do see this in the dmseg log but I can’t say for sure it’s related

[665193.310059] php5[18239]: segfault at 5 ip 0000000000704620 sp 00007fffcb83dc98 error 6 in php5[400000+804000]


#3

Hi,

We found this error in the logs,

[30-Jul-2018 13:27:19 UTC] PHP Warning:  Unknown: Input variables exceeded 1000. To increase the limit change max_input_vars in php.ini. in Unknown on line 0

Increasing max_input_vars in the php.ini solved the issue.