Archiving Error when Updating ISP Database

My Matomo instance (On-Premise) is giving me the following errors when running the archiving function (during cron job and manual run):

/matomo/plugins/GeoIp2/GeoIP2AutoUpdater.php(175): GeoIP2AutoUpdater: failed to download ''
curl_exec: Could not resolve host: Hostname requested was:

Looking this up, I noticed all of the posts around 2018 or 2019 saying Maxmind was no longer free and that the default database was going to be switched to dbip city lite, which my company is fine with. I can confirm that the setting in Matomo for the “Location Database” is the dbip URL (

That said, I still get the issue above, and I can’t help but notice the “ISP Database” in the Geolocation Settings has a disabled text input field with the URL listed above in the error. I notice the field does have a “name” attribute, so I’m sure I could just enable the field in DevTools and submit an empty value, but I don’t know if that’s the right thing to do or if it would even do anything (or let me even try submitting). I don’t know that we need an ISP database for what we’re doing with the analytics, unless it’s used for other processes in Matomo. In short, how do I resolve this?

P.S. There’s a whole laundry list of issues that came about along with this one, but this is the last thing that I can’t seem to figure out. For brevity (though not much apparently), I’ve left out how I got to this point, but I can mention that too if it’s relevant.


Honestly the only reason why the field might be disabled is because you have the “providers” plugin disabled. Maybe try enabling it first, so see if it works (of course the update shouldn’t fail without it and Matomo should also have replaced the URL automatically in an earlier update)