AnonymizeIP doesn't work (V 1.4)


#1

Hi experts,
after upgrading from 1.1 to 1.4 (which worked fine) I activated the anoymizeIP Plugin.
But still can see the full ip-adress in the visitor-trace-log.
The last number is not 0.

And yes,
ip_address_mask_length = 1
is set in the global.ini.php
And
PluginsInstalled[] = "AnonymizeIP"
is set in the config.ini.php

TIA Steve


(vipsoft) #2

Make sure you also see it under:


[Plugins_Tracker]


#3

Yes, its also listed there.


(vipsoft) #4

Check to see if you have duplicate entries in global.ini.php and config.ini.php. I’m guessing there’s an extra:


ip_address_mask_length = 0


#5

No, sorry.
There is no other setting like this in the config files.


(yato) #6

hi steve,

Edit: Sorry, i misread the problem. I thought it was about the database value not the Live! plugin values.

i had/have the same issue. But if i set


 ip_address_mask_length = 4

the saved IP in my database is 0.

I am ‘guessing’ that the database format is different than piwiks. This results in not cutting the last byte of the IP. But i think the saved IP is still not the real one if you have a mask value of at least 1.

Could you please try a value of 4 and report if you get a different result?

regards


#7

Nobody knows what is wrong ?

On another server (fresh installation) everything works fine.

So it has to do something with the upgrade process.

TIA Steve


(vipsoft) #8

To be clear, when you activate the plugin, AnonymizeIP only affects new visits. It doesn’t retroactively anonymize previously logged visits.


#9

Yes, I’m only looking at new visits.
But even with ip_address_mask_length = 4 I can see the full ip address.

:frowning:

Steve


(vipsoft) #10

PM your piwik url+login and ftp host+login. We’ll take a look.