Anfänger sucht Hilfe


#1

Liebe Forums-Teilnehmer

Ich bin in Sachen Piwik blutiger Anfänger, entwickle aber angesichts der vielen Möglichkeiten Ambitionen und eine gesunde Neugierde.

Piwik läuft bei mir, um meine Wordpress-Website (eine kleine Geschäfts-Website mit 80+ Blog-Beiträgen und an die 20 Seiten) einigermassen präzise zu beobachten und zu bewirtschaften, und da möchte ich auch etwas genauer reinsehen – was wurde gesucht? was ist der Nutzerverlauf innerhalb der Site etc. – aber die meisten Widgets in Piwik sind leer.

Gibt es irgendwo einigermassen aktuelle Anleitungen und Erklärungen, die auch eine IT-Banause/nicht-Programmierer nachvollziehen kann? (Darf auch in englisch sein)

vielen Dank, liebe Grüsse aus der Schweiz

odemine


(Stefan Giehl) #2

Wie genau hast du das Tracking denn eingebunden?
Über das JavaScript-Pixel? Falls du Log-Analyse verwendet kann es sein dass manche Daten nicht erhoben werden können.
Sind es nur bestimmte Widgets die leer bleiben, oder ist es eher der großteil und nur einige wenige funktionieren?
Welche gehen bzw. gehen nicht?


#3

Hallo SteveG

Vielen Dank für die Rückfragen.

Ich tracke per tracking-code, eingebettet in die Wordpress-Dateien per


Nutze JS/index.php
im Fussbereich, ohne <noscript>
content-tracking ist [b]deaktiviert[/b]

Soweit ich sehe, ist kein tracking-pixel “da”.

Im Dashboard sind die Seiten, Keywords, Referrer, Plugins, Seitensuche leer.
Auf der Piwik-Seite werden alle Widgets in den Tabs “Dashboard”, “Besucher”, sowie die ersten 4 Widgets vom Tab “Aktionen” ausgewertet, danach bleibt alles leer (“Es stehen keine Daten für diese Aktion zur Verfügung”). Wie wenn Piwik abgebrochen hätte…

Kannst du mit diesen Informationen was anfangen?

Vielen Dank, verregnete Grüsse aus der Schweiz

odemine


(Stefan Giehl) #4

Also prkatisch kann das schonmal passieren, dass Piwik auf Grund eines Fehler die weitere Berechnung der Daten abbricht und nur Teile zur Verfügung stehen. Dies sollte aber spätestens nach der nächsten Berechnung wieder funktionieren (insofern nicht wieder ein Fehler auftritt).

Funktioniert das ganze denn mittlerweile wieder? Falls nein: Hast du Zugriff auf die Error-Logs von PHP? Möglicherweise lässt sich da ein Fehler finden, der auf die Ursache hinweist.