"An error occurred"


#1

A fresh installation. I can log in, but when I click for the second time on a menu item (another option perhaps), matomo throws me out with this error message:
"

An error occurred

Session must be started before any output has been sent to the browser; output started in /www/htdocs/w018af01/praesenz-web.de/matomo/core/bootstrap.php/32

"
Some time later I can log in again, but cannot do much (see above…)

Above the error message it says:
"
Warning : session_cache_limiter(): Cannot change cache limiter when session is active in /www/htdocs/w018af01/praesenz-web.de/matomo/core/bootstrap.php on line 32
"

Only one session is active at a time, this cannot be the cause.
I am happy to receive a solution, please for a code analphabet.
Thanks!


(Fabian Dellwing) #2

Do you have a reverse proxy before your Matomo instance?


#3

Thanks Fabian,
but just now I found the cause, I think.
When I disable NinjaFireWall it works.
Now I have to find out how I can whitelist matomo in the firewall… the next support request there… :wink:

Edit for those who have similar problems with Ninja/matomo combination: I found the solution, building a special file, on the support page of the Ninja Plugin: Admin blocked by NF!? | WordPress.org