All Pages Very Slow - New Install


(Tony Basallo) #1

There have been quite a few posts around this topic, but all seem to have very specific issues or very old.

My environment is:

  • New install - not much activity
  • version 3.5.1
  • Dedicated mySQL server, one database (this one) - no other tables or website accessing
  • php 7.2
  • Windows 2012, IIS
  • Behind corporate proxy/firewall

ALL page loads are extremely slow. Excruciatingly slow. As super or normal user (admin is slower).

Examples are warm starts and back of the napkin averages with cached assets.

tracker code: 800ms - 1.5s (LAN, that’s a big deal)

Dashboard: Initial document load, 6.3 seconds - every widget after that is another average of 6 seconds. This can take 2 minutes as an admin.

Settings: This is the worst - luckily we don;t have to come here after setting up - but setup is painful.

  • 46s - ?module=CoreAdminHome&action=home (document)
  • 1.4s - ?module=CoreHome&action=getSystemSummary (xhr)
  • 59s - ?module=CoreHome&action=getDonateForm (xhr)
  • 16s - ?module=Installation&action=getSystemCheck (xhr)
  • timeout/error - marketplace

I am looking through some of the articles on improving performance, but is this normal for a new install?


(Tony Basallo) #2

After going through GitHub, I found this issue Incorrect proxy settings lead to slow page loading · Issue #13241 · matomo-org/matomo · GitHub and a few other like it related to the Marketplace. Sure enough, disabling the Marketplace plugin did improve speeds tremendously (if not completely).

What’s going on with the marketplace?

I’m going to do some testing to ensure that this is the issue. I am not sure why the marketplace plugin should affect every single page in the entire app - seems a little heavy handed. What would it add?

As a side note, the marketplace section never worked for me - so this make sense.

This is a great issue and a config setting that really addresses the issue:


(Lukas Winkler) #3

Hi,

The issue is that the marketplace (and some other features) has to connect to the internet to work. But it seems like your server doesn’t have a direct connection to the internet, but every connection Matomo tries to make hangs for a while until it times out.

So you can either get internet to work on your server (maybe you have to configure the proxy or disable all internet features completely with the new option.


(Tony Basallo) #4

So, for an update. This internet settings did not help. I shut down internet access, using the following:

enable_trusted_host_check = 0
enable_internet_features = 0
enable_marketplace = 0
enable_auto_update = 0
enable_update_communication = 0

Tracker code runs from 500ms to 1s,
Using the portal is painful. Look at some of these times on the portal. I’;m just not sure if it’s a proxy issue, code, server or mySQL.