Again - Problem Update 0.5.1


(XSK8) #1

Sorry but now i start to feel “just too dumb” for this…

I did the Update maually like in an other insallation before.

  • saved the config
  • unzipped the latest.zip -fr on the server
  • restored the config

The DB entry for the old shows: version_core 0.2.31 | Im not sure if this is possible because it was updated lately…

When I go to piwik in the Browser now i get this:

Use of undefined constant PIWIK_USER_PATH - assumed 'PIWIK_USER_PATH’
in ‘/****/piwik/core/Piwik.php’ at the line 89

#0 Piwik_ErrorHandler(8, Use of undefined constant PIWIK_USER_PATH - assumed ‘PIWIK_USER_PATH’, //piwik/core/Piwik.php, 89, Array ([directoriesToCheck] => Array ([0] => /tmp,[1] => /tmp/templates_c,[2] => /tmp/cache),[resultCheck] => Array (),[directoryToCheck] => /tmp)) called at [//piwik/core/Piwik.php:89]
#1 Piwik::checkDirectoriesWritable(Array ([0] => /tmp,[1] => /tmp/templates_c,[2] => /tmp/cache)) called at [//piwik/core/Piwik.php:44]
#2 Piwik::checkDirectoriesWritableOrDie(Array ([0] => /tmp,[1] => /tmp/templates_c,[2] => /tmp/cache)) called at [/
/piwik/core/FrontController.php:194]
#3 Piwik_FrontController->init() called at [/****/piwik/index.php:52]

Please help - I’m lost in PIWIK-Space …


(XSK8) #2

I had the insallation open in an other browser window here it shows Piwik 0.4.2 before updaing…


(Matthieu Aubry) #3

It looks like the file were not overwritten? Please make sure all the files are overwritten with the 0.5.1 files