After updating the piwik nginx was producing an error 502


#1

Hello.

In nginx error log:

2012/06/03 11:08:54 [error] 10933#0: *1 recv() failed (104: Connection reset by peer) while reading response header from upstream, client: ******, server: webmaster.example.com, request: “GET /index.php?module=MultiSites&action=index&idSite=1&period=range&date=last7 HTTP/1.1”, upstream: “fastcgi://unix:/var/run/fpm/webmaster.example.com.sock:”, host: “webmaster.example.com

nginx version: nginx/1.2.0
PHP 5.3.13-1~dotdeb.0 with Suhosin-Patch (cli) (built: May 8 2012 21:47:56)
Copyright © 1997-2012 The PHP Group
Zend Engine v2.3.0, Copyright © 1998-2012 Zend Technologies
with eAccelerator v0.9.6.1, Copyright © 2004-2010 eAccelerator, by eAccelerator
with Suhosin v0.9.33, Copyright © 2007-2012, by SektionEins GmbH

piwik 1.8

Tell me please, where to find the problem?


(Matthieu Aubry) #2

Where are the fastcgi errors logged?

To prevent this error make sure you setup the cron as per: How to Set up Auto-Archiving of Your Reports - Analytics Platform - Matomo


#3

$ sudo crontab -l |grep webmaster
*/60 * * * * /var/www/webmaster.example.com/misc/cron/archive.sh --url=https://webmaster.example.com/ --accept-invalid-ssl-certificate > /dev/null 2>&1


$ sudo cat /var/log/php5-fpm.log
[03-Июн-2012 13:16:07] NOTICE: fpm is running, pid 9361
[03-Июн-2012 13:16:07] NOTICE: ready to handle connections
[03-Июн-2012 13:16:26] WARNING: [pool webmaster] child 9388 exited on signal 11 (SIGSEGV) after 19.578169 seconds from start
[03-Июн-2012 13:16:26] NOTICE: [pool webmaster] child 9725 started

before the upgrade it worked fine …


#4

hm. I had to re-set the chmod to all folders and files to piwik, and then everything worked fine.