After update to 2.14 allways error!


#1

After update to 2.14 and changint http to https PIWIK allways display error:

ssl.error.log

Error on LVE enter -7 LVE id 125558, referer: https://domain.com/piwik/index.php?module=CoreHome&action=index&idSite=1&period=day&date=yesterday

[quote="[Wed Aug 5 20:28:26 2015] [error] Error on lve_setup_enter -7 LVE id 125558"]
[/quote]


#2

Bump. Helo. Help Needed!


(Matthieu Aubry) #3

Hi there,

Can you try upgrade your PHP version? this should fix the problem


#4

I can change PHP between 5.3.3 and 5.4.40 and 5.5.24. After check system in PIWIK settings I have some errors:

  1. shell_exec You need to enable this built-in function.

  2. LOAD DATA INFILE
    Using LOAD DATA INFILE will greatly speed Piwik’s archiving process up. To make it available to Piwik, try updating your PHP & MySQL software and make sure your database user has the FILE privilege.
    If your Piwik server tracks high traffic websites (eg. > 100,000 pages per month), we recommend to try fix this problem.
    Błąd: LOAD DATA INFILE failed… Error was:
    Try #1: LOAD DATA INFILE : SQLSTATE[28000]: Invalid authorization specification: 1045 Access denied for user ‘user’@’%’ (using password: YES)[28000]
    Troubleshooting: FAQ on piwik.org


(Matthieu Aubry) #5

it’s recommended to enable shell_exec function, it is recommended to run Piwik correctly (but not required)