After update to 1.6 tracking stopped working

Updated from 1.5.1 to 1.6 over a week ago and tracking has been broken since, every visit creates a new row with data in the piwik_log_visit table but the Piwik admin interface refuses to acknowledge these visits. Why?

[attachment 415 Skrmavbild2011-11-08kl.15.49.05.png]

I have the same problem, piwik stopped tracking since yesterday. Are there more people with the same problem?

Are visits displayed in the Real time widget or the Visitor Log?

Do you use a cron script or default browser archiving?

Not in the real time visit and not in the visitor log. I use the default browser archiving

Not visible in the real time widget or visitor log. I do use cron (/misc/cron/archive.php) which runs at 45 * * * * edit: Cron reports a result of “200” any time it runs.

OK if you don’t have data in the Visitor log then tracking is really not working. Please look at your error logs. What are your website URL with piwik tracking cookie?

Also see the list in: Troubleshooting - Analytics Platform - Matomo

No errors.

Every time someone visits the site the piwik_log_visit table in the database gets a new entry

This is what just registered when I reloaded the page:

847	23	è<	CÂËô‘	01:39:25	1	30	0	0	3	2011-11-11 00:39:25	2011-11-11 00:39:25	351	259	351	259	1	0	0	0	1				¢_åA#	MAC	SF	5.1	2560x1440	0	0	1	0	1	0	0	0	0	1	mä˜	sv-se	se	eur	NULL	NULL	NULL	NULL	NULL	NULL	NULL	NULL	NULL	NULL

That line looks correct. Have you tried tracking other websites?

It looks very similar:

860	24	¯ð´’>™‡	14:58:29	0	1	0	0	0	2011-11-11 13:58:29	2011-11-11 13:58:29	246	211	246	211	1	0	0	0	1				Æ-ªîÅsÉ°	MAC	SF	5.1	2560x1440	1	0	1	0	1	0	0	0	0	1	mä˜	sv-se	se	eur	NULL	NULL	NULL	NULL	NULL	NULL	NULL	NULL	NULL	NULL

None of your website work, all show “no data” ? Did you see any errors in your webserver error logs?

No errors.

I can’t see any data anywhere unless I look directly into the SQL data table.

Can you pleases end me an email with link to this forum post, piwik usernames, phpmyadmin usernames?

i’ll look into it (matt att piwik)

matt, I sent you the login credentials on saturday, have you had any time to look at this?

I reinstalled piwik manually, but the problem stays. Does the piwik team know what causes this bug?

I don’t know, it is over five days since I sent matt login credentials and he has not responded. I wonder if I should change them immediately and if this was a phishing attempt that succeeded?

Don’t get paranoid guys.

It looks like a serious error, so naturally it takes a while to write a good fix for it. Hang tight!

It’s the complete and utter radio silence that bothers me!

Thanks Niklas for your details! Sorry I was overloaded, I will look into it in the next day

See also: 301 Moved Permanently

Thanks matt!

Returning to this thread to report to the community.

1.6 simply does not work and after a long time of trying (even with the help of matt, thank you) we have decided to downgrade to 1.5.1 where everything worked as it should.