"Access denied." before reaching login page after server restart

I successfully installed Piwik on my server two weeks ago. However, now when I try and access Piwik it just gives me a page that says “Access denied.” and is otherwise completely empty/blank (i.e. no login at all). I restarted the server recently (since getting Piwik running) so I thought maybe I didn’t have some service running correctly, but service --status-all shows both MariaDB (mysql) and PHP (php7.0-fpm) are running.

I am running Piwik via nginx so maybe something in my configuration is the problem? But nothing changed in the nginx config between when it worked and when it stopped working. In any case here is the relevant part of my /var/lib/nginx/sites-available/default file:

location /piwik {
  root /home/[myusername]/;
  index index.php index.html index.htm;
  location ~ [^/]\.php(/|$) {
    fastcgi_split_path_info ^(.+?\.php(/.*)$;
    fastcgi_pass unix:/run/php/php7.0-fpm.sock;
    fastcgi_index index.php;
    include fastcgi_params;

Nginx logs the following error when trying to access the [myserver.com]/piwik/ directory, where I have Piwik set up. (which worked before)

2017/07/20 12:14:46 [error] 12366#12366: *3795 FastCGI sent in stderr: "Access to the script '/home/[myusername]' has been denied (see security.limit_extensions)" while reading response header from upstream, client:, server: [myserver.com], request: "GET /piwik/ HTTP/1.1", upstream: "fastcgi://unix:/run/php/php7.0-fpm.sock:", host: "[myserver.com]"

Thanks for any advice!