About automatic analytics ( cron )


#1

Our site’s average daily traffic:
IP 80,000
PV 400,000

Piwik version:1.1.1

Piwik has been running well on our site, but recently we found that it was very slow to visit the analytic data. We have no idea what happened.
When we set “Allow Piwik archiving to trigger when reports are viewed from the browser” to Yes, the page of the analytics reports will keep loading, furthermore, the number of apache requests on our server will also keep increasing and the report page still won’t show.

When we set ”Allow Piwik archiving to trigger when reports are viewed from the browser” to No and enable the automatic analytics function (cron), the analytic progress will keep running for a long time (half a day, one day or even two days) but still cannot get a final result.
Remarks: The analytic script didn’t generate any error info (misc/cron/archive.sh).

As for our site with such visiting traffic and the problems we encountered, is there anything about the Piwik settings we should pay special attention to? Or can you offer us any suggestions for optimization? Can you help us figure out why the analytic progress cannot be completed successfully?


(vipsoft) #2

Sounds like some limit was reached. Check the web server error log.

Check that the execute (x) bit is set on the archive.sh script when using cron.


#3

OK. let me have a check~ 3Q


#4

The problems:

1.when run archive.sh , there is not error hint, and it takes very long time to finish(shut down the web-server) or always runing(did not shut down the web-server);

2.when get in the piwik , the auto-Statistic system run a long time,but the result did not come out.


#5

MyServer version :

FreeBSD 7.3-RELEASE + php 5.2.14 + mysql 5.1.51


(Matthieu Aubry) #6

limjr, please disable the Live! plugin, it has performance issues in 1.1.1

is it working fine after disabling the plugin?


#7

I have tried, but it didn’t work.
However It now works well after I reinstall the piwik system.
Thank you all the same !
Best wishes.