504 Gateway Time-out / Piwik installation not working

Hello all,

I’ve installed yesterday piwik on server (hosting OVH)
No problem, I configured, custom and could track visitors as expected.

The day after, no way to access piwik from any browser nor PC. After typing the url and waiting some time, I get the message " 504 Gateway Time-outThe server didn’t respond in time."

Thinking my host provider had some issues, I waited some hours: problem still there.

I uninstalled and tried to re-installed piwik: after FTP upload (in binary mode), I still get the 504 error and cannot get the instal page anymore.

Some info:
piwik version: 2.16.2
host: ovh
php version: 5.6
SSL certicate: yes

I didn’t find similar users issues anywhere and I’m actually not that clear with the meaning of 504 Gateway Time-outThe server didn’t respond in time.

Does anybody have an idea about the issue?

Thanks in advance for any support,

Hi there,
I solved the issue by my own by changing the php by phpcgi. By this it works again without problem.


Hi Nico,
can you reply what you changed to fix this?