404 while database creation

Recently configured matomo with nginx and php-fpm. On the second step of installation (database creation) I got 404 error and redirect the URL to : /index.php?action=tablesCreation&clientProtocol=https&module=Installation?
have tried to increase php execution time, nginx read time out, but none fix the issue.
Also I couldn’t find any Queries running on mysql server, any other settings need to be changed?


The installer should never create a 404 error. Does the /index.php file exist?

Maybe also take a look at this nginx config for inspiration:

Have tried with mentioned nginx conf, but still seeing 404, I was trying to configure this in container, will try to configure in local and let you know if the issue persists.