4.11.0 uses http instead of https to contact marketplace

I’m testing the upgrade to 4.11.0 in our dev system and it tries to go to plugins.matomo.org via http instead of https, getting blocked by our forward proxy, even though I’ve set the “force_matomo_http_request = 0” in the general segment of the config.ini.php? The admin page gets big red boxes and the marketplace links to add new plugins fail.

who is it? The old version (which one?) or the 4.11 one?

Before the upgrade we were running 4.9.0, which worked fine, the 4.11.0 attempts to reach the http://plugins.matomo.org/ when opening the administration page or the marketplace page from the plugins.

Hi @SebArblaster are any errors being thrown or visible as this occurs?

On the administration page I get 2 white on red “Oops… there was a problem during the request” boxes instead of the “Premium Features” and the “Latest Marketplace Updates” box and red on white “Oops… there was a problem during the request” box at the top of the page. The marketplace page is just the big “An error occurred” message with “There was an error reading the response from the Marketplace: Please try again later.”

Are you in multi-server environment? If yes, can you confirm you share the same config.ini.php file or that you set force_matomo_http_request = 0 on each server?
Did you check also the value of api_service_url?
Can you check on the log file the source of your Oops?

The mysql server is separate, only one matomo server though.
The setting is in both files (first error with it only in the global):
config.ini.php:force_matomo_http_request = 0
global.ini.php:force_matomo_http_request = 0
If I add the http:/plugins.matomo.org URL to the allowed URL’s in the forward proxy the errors go away.
I opened the question as this is not my understanding of how this setting should be working, it should be https only except if the force_matomo_http_request is set to 1, then http only?
global.ini.php:api_service_url = http://api.matomo.org
(neither https or http to the api.matomo.org are currently allowed in the forward proxy)

@V.K any other clue?
The Matomo version seems to be the latest…